aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/lua
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-19 18:33:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-19 18:33:13 +0000
commit5199a2316571d0d5e9ea6103894479e2e2ec1a16 (patch)
tree10be80cc1702ca55a12a927d6ca7590c1341e372 /package/utils/lua
parentd2ecd10f2fd1868bc45989a4670e91c8cce87699 (diff)
downloadupstream-5199a2316571d0d5e9ea6103894479e2e2ec1a16.tar.gz
upstream-5199a2316571d0d5e9ea6103894479e2e2ec1a16.tar.bz2
upstream-5199a2316571d0d5e9ea6103894479e2e2ec1a16.zip
lua: link library with -Bsymbolic-functions
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45509
Diffstat (limited to 'package/utils/lua')
-rw-r--r--package/utils/lua/patches/040-use-symbolic-functions.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/utils/lua/patches/040-use-symbolic-functions.patch b/package/utils/lua/patches/040-use-symbolic-functions.patch
new file mode 100644
index 0000000000..f59069557d
--- /dev/null
+++ b/package/utils/lua/patches/040-use-symbolic-functions.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -56,7 +56,7 @@ $(LUA_A): $(CORE_O) $(LIB_O)
+ $(RANLIB) $@
+
+ $(LUA_SO): $(CORE_O) $(LIB_O)
+- $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
++ $(CC) -o $@.$(PKG_VERSION) -Wl,-Bsymbolic-functions -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
+ ln -fs $@.$(PKG_VERSION) $@
+
+ $(LUA_T): $(LUA_O) $(LUA_SO)