aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/lua
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2019-06-28 11:38:23 +0200
committerRafał Miłecki <rafal@milecki.pl>2019-06-28 11:40:08 +0200
commit24645c0ee1103235338737fb3c4478f3c4109bc1 (patch)
tree82e2dec0c04d2e3b10ed799b6304c6bdc4cedec5 /package/utils/lua
parent6b161bb8d528663b78c2314d9f1e1c9217dacba2 (diff)
downloadupstream-24645c0ee1103235338737fb3c4478f3c4109bc1.tar.gz
upstream-24645c0ee1103235338737fb3c4478f3c4109bc1.tar.bz2
upstream-24645c0ee1103235338737fb3c4478f3c4109bc1.zip
lua: fix build with MacOS's make
It apparently requires passing V variable explicitly. Fixes: fe59b46ca7e0 ("lua: include version number in installed files") Reported-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'package/utils/lua')
-rw-r--r--package/utils/lua/patches-host/001-include-version-number.patch9
-rw-r--r--package/utils/lua/patches/001-include-version-number.patch9
2 files changed, 18 insertions, 0 deletions
diff --git a/package/utils/lua/patches-host/001-include-version-number.patch b/package/utils/lua/patches-host/001-include-version-number.patch
index b7056fd47c..f769e60736 100644
--- a/package/utils/lua/patches-host/001-include-version-number.patch
+++ b/package/utils/lua/patches-host/001-include-version-number.patch
@@ -24,6 +24,15 @@ diff --git a/Makefile b/Makefile
# Lua version and release.
V= 5.1
+@@ -53,7 +53,7 @@ R= 5.1.5
+ all: $(PLAT)
+
+ $(PLATS) clean:
+- cd src && $(MAKE) $@
++ cd src && $(MAKE) $@ V=$V
+
+ test: dummy
+ src/lua test/hello.lua
diff --git a/doc/lua.1 b/doc/lua5.1.1
rename from doc/lua.1
rename to doc/lua5.1.1
diff --git a/package/utils/lua/patches/001-include-version-number.patch b/package/utils/lua/patches/001-include-version-number.patch
index b7056fd47c..f769e60736 100644
--- a/package/utils/lua/patches/001-include-version-number.patch
+++ b/package/utils/lua/patches/001-include-version-number.patch
@@ -24,6 +24,15 @@ diff --git a/Makefile b/Makefile
# Lua version and release.
V= 5.1
+@@ -53,7 +53,7 @@ R= 5.1.5
+ all: $(PLAT)
+
+ $(PLATS) clean:
+- cd src && $(MAKE) $@
++ cd src && $(MAKE) $@ V=$V
+
+ test: dummy
+ src/lua test/hello.lua
diff --git a/doc/lua.1 b/doc/lua5.1.1
rename from doc/lua.1
rename to doc/lua5.1.1