aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/jboot-tools/Makefile
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2018-03-01 20:11:01 +0100
committerMathias Kresin <dev@kresin.me>2018-03-18 22:22:38 +0100
commit5323477184cf39f4f20003142ce320ac1d626863 (patch)
tree81d205cafa0747245f9958491ff8cfbacc902ebc /package/utils/jboot-tools/Makefile
parent84c1b786b9830c17034e5de915ce11965666febd (diff)
downloadupstream-5323477184cf39f4f20003142ce320ac1d626863.tar.gz
upstream-5323477184cf39f4f20003142ce320ac1d626863.tar.bz2
upstream-5323477184cf39f4f20003142ce320ac1d626863.zip
firmware: add JBOOT based devices config extractor
Adds tool to extract MAC and pre-calibration data required for JBOOT based D-Link routers. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'package/utils/jboot-tools/Makefile')
-rw-r--r--package/utils/jboot-tools/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/utils/jboot-tools/Makefile b/package/utils/jboot-tools/Makefile
new file mode 100644
index 0000000000..ce9758ba3a
--- /dev/null
+++ b/package/utils/jboot-tools/Makefile
@@ -0,0 +1,28 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=jboot-tools
+PKG_RELEASE:=1
+CMAKE_INSTALL:=1
+PKG_FLAGS:=nonshared
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/jboot-tools
+ SECTION:=firmware
+ CATEGORY:=Firmware
+ DEPENDS:=@TARGET_ramips
+ TITLE:=Utilites for accessing JBOOT based D-Link devices Calibration data
+endef
+
+define Package/jboot-tools/description
+ This package contains:
+ jboot_config_read.c: partially read the config partition of JBOOT based D-Link devices.
+endef
+
+define Package/jboot-tools/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/jboot_config_read $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,jboot-tools))