aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/f2fs-tools
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2020-02-04 01:10:17 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2020-02-22 16:38:41 +0100
commitf0864cb31be59c550625379d3f60aa1b61743b4f (patch)
treecbf50d54f26fd143dc24bd90a2cc3737739c7be2 /package/utils/f2fs-tools
parentc6e33b7cb4e07af312068a8b549aa1daa0e6d872 (diff)
downloadupstream-f0864cb31be59c550625379d3f60aa1b61743b4f.tar.gz
upstream-f0864cb31be59c550625379d3f60aa1b61743b4f.tar.bz2
upstream-f0864cb31be59c550625379d3f60aa1b61743b4f.zip
package/utils/f2fs-tools: Update to 1.13.0
Update f2fs-tools to 1.13.0 Remove upstreamed patches Disable build of static library Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'package/utils/f2fs-tools')
-rw-r--r--package/utils/f2fs-tools/Makefile8
-rw-r--r--package/utils/f2fs-tools/patches/010-fsck-Fix-big-endian-platforms.patch35
-rw-r--r--package/utils/f2fs-tools/patches/020-dump.f2fs-fix-incorrect-endian-conversion.patch24
3 files changed, 4 insertions, 63 deletions
diff --git a/package/utils/f2fs-tools/Makefile b/package/utils/f2fs-tools/Makefile
index 8f52bca152..8c7d958c7e 100644
--- a/package/utils/f2fs-tools/Makefile
+++ b/package/utils/f2fs-tools/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=f2fs-tools
-PKG_VERSION:=1.12.0
-PKG_RELEASE:=3
+PKG_VERSION:=1.13.0
+PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/snapshot/
-PKG_HASH:=e2124e4dffaba865d41495d817bcb924d096adaec67ff777b8c7da99aa13f696
+PKG_HASH:=b39d3ae9224267aab0070b5f17d91d0c5143f6d960166a27f6b11c8c87072c7d
PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
@@ -58,6 +58,7 @@ define Package/libf2fs
endef
CONFIGURE_ARGS += \
+ --disable-static \
--without-selinux \
--without-blkid
@@ -77,7 +78,6 @@ endef
define Package/f2fsck/install
$(INSTALL_DIR) $(1)/usr/sbin
-
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/fsck.f2fs $(1)/usr/sbin
ln -s /usr/sbin/fsck.f2fs $(1)/usr/sbin/defrag.f2fs
ln -s /usr/sbin/fsck.f2fs $(1)/usr/sbin/dump.f2fs
diff --git a/package/utils/f2fs-tools/patches/010-fsck-Fix-big-endian-platforms.patch b/package/utils/f2fs-tools/patches/010-fsck-Fix-big-endian-platforms.patch
deleted file mode 100644
index 4410d0fcd8..0000000000
--- a/package/utils/f2fs-tools/patches/010-fsck-Fix-big-endian-platforms.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 46772bbf0d978512423923da461ceb6b6e791c91 Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Fri, 7 Dec 2018 17:39:03 -0800
-Subject: [PATCH] fsck: Fix big endian platforms
-
-Since "fsck.f2fs: integrate sanity_check_inode to __check_inode_mode",
-big endian platforms have been broken due to an endianness bug.
-
-More info: https://github.com/openwrt/openwrt/pull/1575
-
-Signed-off-by: Rosen Penev <rosenp@gmail.com>
----
- fsck/fsck.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/fsck/fsck.c
-+++ b/fsck/fsck.c
-@@ -339,7 +339,7 @@ out:
- return ret;
- }
-
--static int __check_inode_mode(u32 nid, enum FILE_TYPE ftype, u32 mode)
-+static int __check_inode_mode(u32 nid, enum FILE_TYPE ftype, u16 mode)
- {
- if (ftype >= F2FS_FT_MAX)
- return 0;
-@@ -457,7 +457,7 @@ static int sanity_check_nid(struct f2fs_
- return 0;
-
- if (ntype == TYPE_INODE &&
-- __check_inode_mode(nid, ftype, le32_to_cpu(node_blk->i.i_mode)))
-+ __check_inode_mode(nid, ftype, le16_to_cpu(node_blk->i.i_mode)))
- return -EINVAL;
-
- /* workaround to fix later */
diff --git a/package/utils/f2fs-tools/patches/020-dump.f2fs-fix-incorrect-endian-conversion.patch b/package/utils/f2fs-tools/patches/020-dump.f2fs-fix-incorrect-endian-conversion.patch
deleted file mode 100644
index 2420ec889f..0000000000
--- a/package/utils/f2fs-tools/patches/020-dump.f2fs-fix-incorrect-endian-conversion.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From a1241763f50d20efc42910e922b9c8845814f024 Mon Sep 17 00:00:00 2001
-From: Chao Yu <yuchao0@huawei.com>
-Date: Sun, 9 Dec 2018 19:41:52 -0800
-Subject: [PATCH] dump.f2fs: fix incorrect endian conversion
-
-f2fs_inode.i_mode is variable of __le16 type, during endian converison,
-it should to use le16_to_cpu instead of le32_to_cpu, fix it.
-
-Signed-off-by: Chao Yu <yuchao0@huawei.com>
----
- fsck/dump.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/fsck/dump.c
-+++ b/fsck/dump.c
-@@ -407,7 +407,7 @@ static void dump_file(struct f2fs_sb_inf
- struct f2fs_node *node_blk, int force)
- {
- struct f2fs_inode *inode = &node_blk->i;
-- u32 imode = le32_to_cpu(inode->i_mode);
-+ u32 imode = le16_to_cpu(inode->i_mode);
- u32 namelen = le32_to_cpu(inode->i_namelen);
- char name[F2FS_NAME_LEN + 1] = {0};
- char path[1024] = {0};