aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/f2fs-tools
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-22 19:17:32 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-24 10:39:30 +0100
commit0e70f69a35fd79be781c859c12487b626e243e96 (patch)
tree2025021f55f831e09f0f102969e01532881b8147 /package/utils/f2fs-tools
parent60558790a2a832265ec041131e851b6648f514d4 (diff)
downloadupstream-0e70f69a35fd79be781c859c12487b626e243e96.tar.gz
upstream-0e70f69a35fd79be781c859c12487b626e243e96.tar.bz2
upstream-0e70f69a35fd79be781c859c12487b626e243e96.zip
treewide: revise library packaging
- Annotate versionless libraries (such as libubox, libuci etc.) with a fixed ABI_VERSION resembling the source date of the last incompatible change - Annotate packages shipping versioned library objects with ABI_VERSION - Stop shipping unversioned library symlinks for packages with ABI_VERSION Ref: https://openwrt.org/docs/guide-developer/package-policies#shared_libraries Ref: https://github.com/KanjiMonster/maintainer-tools/blob/master/check-abi-versions.pl Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/utils/f2fs-tools')
-rw-r--r--package/utils/f2fs-tools/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/utils/f2fs-tools/Makefile b/package/utils/f2fs-tools/Makefile
index b782b80670..8a264c5111 100644
--- a/package/utils/f2fs-tools/Makefile
+++ b/package/utils/f2fs-tools/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=f2fs-tools
PKG_VERSION:=1.12.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPLv2
@@ -54,6 +54,7 @@ define Package/libf2fs
CATEGORY:=Libraries
TITLE:=Library for Flash-Friendly File System (F2FS) tools
DEPENDS:=+libuuid
+ ABI_VERSION:=6
endef
CONFIGURE_ARGS += \
@@ -66,7 +67,7 @@ CONFIGURE_VARS += \
define Package/libf2fs/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) \
- $(PKG_INSTALL_DIR)/usr/lib/libf2fs.so* $(1)/usr/lib/
+ $(PKG_INSTALL_DIR)/usr/lib/libf2fs.so.* $(1)/usr/lib/
endef
define Package/mkf2fs/install