aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/e2fsprogs
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-11-30 23:25:17 +0100
committerJo-Philipp Wich <jo@mein.io>2016-11-30 23:32:17 +0100
commit4596f9b5ac4278d544040b2b3fc9ec5fce3d2b10 (patch)
treedd06415035fc92f413df55d27949f9421b55f8c3 /package/utils/e2fsprogs
parente678c9f764c37f963e6667777b6a05bddcf05ea5 (diff)
downloadupstream-4596f9b5ac4278d544040b2b3fc9ec5fce3d2b10.tar.gz
upstream-4596f9b5ac4278d544040b2b3fc9ec5fce3d2b10.tar.bz2
upstream-4596f9b5ac4278d544040b2b3fc9ec5fce3d2b10.zip
e2fsprogs: avoid picking up incompatible libcom_err.so
Commit 2728512 ("e2fsprogs: List all libraries explicitly") forced the e2fsprogs build system to link libcom_err.so in various places. Unfortunately, the krb5 package also ships a libcom_err.so with a totally different ABI and puts it into the global staging directory which causes e2fsprogs to pick up this wrong library, leading to the following failure: LD blkid ../lib/libext2fs.so: undefined reference to `_et_list' collect2: error: ld returned 1 exit status Makefile:504: recipe for target 'blkid' failed Change the SYSLIBS specification to explicitely link libcom_err.so.0.0 which in order to work around the problem. In the long run, the libcom_err clash between e2fsprogs and krb5 needs to be solved properly. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/utils/e2fsprogs')
-rw-r--r--package/utils/e2fsprogs/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/utils/e2fsprogs/Makefile b/package/utils/e2fsprogs/Makefile
index 6932a4b17a..cf84c260c7 100644
--- a/package/utils/e2fsprogs/Makefile
+++ b/package/utils/e2fsprogs/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=e2fsprogs
PKG_VERSION:=1.43.3
PKG_MD5SUM:=ce8ef1bbb0d4730f170167284fda156ac9d6bf18db2750eb94af619a81b19927
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/e2fsprogs
@@ -140,7 +140,7 @@ define Build/Compile
DESTDIR="$(PKG_INSTALL_DIR)" \
LIBBLKID="$(PKG_BUILD_DIR)/lib/libblkid.a -luuid" \
ELF_OTHER_LIBS="$(TARGET_LDFLAGS) -luuid" \
- SYSLIBS="$(TARGET_LDFLAGS) -ldl -L$(PKG_BUILD_DIR)/lib/ -lcom_err" \
+ SYSLIBS="$(TARGET_LDFLAGS) -ldl -L$(PKG_BUILD_DIR)/lib/ -l:libcom_err.so.0.0" \
V=$(if $(findstring c,$(OPENWRT_VERBOSE)),1,) \
all
endef