aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/e2fsprogs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-06-28 11:26:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-06-28 11:26:55 +0000
commit1646855141f2eae9a4888adcb63cf2c1365c724c (patch)
tree6e100c616e673ae88eaa6d54f57f1c84d7c4fd55 /package/utils/e2fsprogs
parentd383212f81bd38ab9dfab83533d1d6d46ec4e36d (diff)
downloadupstream-1646855141f2eae9a4888adcb63cf2c1365c724c.tar.gz
upstream-1646855141f2eae9a4888adcb63cf2c1365c724c.tar.bz2
upstream-1646855141f2eae9a4888adcb63cf2c1365c724c.zip
e2fsprogs: use -ffunction-sections, -fdata-sections, --gc-sections
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37066
Diffstat (limited to 'package/utils/e2fsprogs')
-rw-r--r--package/utils/e2fsprogs/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/utils/e2fsprogs/Makefile b/package/utils/e2fsprogs/Makefile
index 783648cf63..e1e9aff3f0 100644
--- a/package/utils/e2fsprogs/Makefile
+++ b/package/utils/e2fsprogs/Makefile
@@ -81,7 +81,8 @@ $(call Package/e2fsprogs)
DEPENDS:= +e2fsprogs
endef
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections
+
CONFIGURE_ARGS += \
--enable-elf-shlibs \
@@ -105,6 +106,7 @@ define Build/Compile
LDFLAGS="" \
subst
$(MAKE) -C $(PKG_BUILD_DIR) \
+ LDFLAGS=-Wl,--gc-sections \
BUILDCC="$(HOSTCC)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
LIBBLKID="$(PKG_BUILD_DIR)/lib/libblkid.a -luuid" \