aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/e2fsprogs
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-22 19:17:32 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-24 10:39:30 +0100
commit0e70f69a35fd79be781c859c12487b626e243e96 (patch)
tree2025021f55f831e09f0f102969e01532881b8147 /package/utils/e2fsprogs
parent60558790a2a832265ec041131e851b6648f514d4 (diff)
downloadupstream-0e70f69a35fd79be781c859c12487b626e243e96.tar.gz
upstream-0e70f69a35fd79be781c859c12487b626e243e96.tar.bz2
upstream-0e70f69a35fd79be781c859c12487b626e243e96.zip
treewide: revise library packaging
- Annotate versionless libraries (such as libubox, libuci etc.) with a fixed ABI_VERSION resembling the source date of the last incompatible change - Annotate packages shipping versioned library objects with ABI_VERSION - Stop shipping unversioned library symlinks for packages with ABI_VERSION Ref: https://openwrt.org/docs/guide-developer/package-policies#shared_libraries Ref: https://github.com/KanjiMonster/maintainer-tools/blob/master/check-abi-versions.pl Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/utils/e2fsprogs')
-rw-r--r--package/utils/e2fsprogs/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/package/utils/e2fsprogs/Makefile b/package/utils/e2fsprogs/Makefile
index 48f812a30c..a40e7bd3a7 100644
--- a/package/utils/e2fsprogs/Makefile
+++ b/package/utils/e2fsprogs/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=e2fsprogs
PKG_VERSION:=1.44.3
PKG_HASH:=5d899f7d30f481cc0c6a049ebe26ebe145f1b524182ea1ecde4086162d4e4bb6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/tytso/e2fsprogs/v$(PKG_VERSION)/
@@ -45,6 +45,7 @@ define Package/libext2fs
TITLE:=ext2/3/4 filesystem library
URL:=http://e2fsprogs.sourceforge.net/
DEPENDS:=+libuuid +libblkid +libss +libcomerr
+ ABI_VERSION:=2
endef
define Package/libext2fs/description
@@ -57,6 +58,7 @@ define Package/libss
TITLE:=command-line interface parsing library
URL:=http://e2fsprogs.sourceforge.net/
DEPENDS:=+libcomerr
+ ABI_VERSION:=2
endef
define Package/libss/description
@@ -70,6 +72,7 @@ define Package/libcomerr
TITLE:=common error description library
URL:=http://e2fsprogs.sourceforge.net/
DEPENDS:=+libuuid
+ ABI_VERSION:=0
endef
define Package/libcomerr/description
@@ -234,12 +237,12 @@ endef
define Package/libcomerr/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcom_err.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcom_err.so.* $(1)/usr/lib/
endef
define Package/libss/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libss.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libss.so.* $(1)/usr/lib/
endef
define Package/libext2fs/install