aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/e2fsprogs/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-07-01 16:41:46 +0200
committerJo-Philipp Wich <jo@mein.io>2016-07-04 16:26:26 +0200
commit70b4e4680461b08e58e1b6d54ebf6980fbb2c61a (patch)
treee7840966a63e6bf424c373fe0f0409495f5c4255 /package/utils/e2fsprogs/Makefile
parenteaf0d2242106fdaa5d91a03c4b7929b76497aaf2 (diff)
downloadupstream-70b4e4680461b08e58e1b6d54ebf6980fbb2c61a.tar.gz
upstream-70b4e4680461b08e58e1b6d54ebf6980fbb2c61a.tar.bz2
upstream-70b4e4680461b08e58e1b6d54ebf6980fbb2c61a.zip
e2fsprogs: fix build on OS X systems
On OS X systems, the compilation of e2fsprogs fails at subst.c due to a missing sys/stat.h include: subst.c:333:14: error: variable has incomplete type 'struct stat' struct stat stbuf; ^ subst.c:333:9: note: forward declaration of 'struct stat' struct stat stbuf; ^ subst.c:392:8: warning: implicit declaration of function 'fstat' is invalid in C99 [-Wimplicit-function-declaration] if (fstat(fd, &stbuf) == 0) { ^ subst.c:438:12: warning: implicit declaration of function 'fchmod' is invalid in C99 [-Wimplicit-function-declaration] (void) fchmod(ofd, 0444); ^ 2 warnings and 1 error generated. make[3]: *** [subst.o] Error 1 Declare the nescessary HAVE_SYS_STAT_H macro to include the required header in order to avoid the undeclared stat structure. Tested-By: David Thornley <david.thornley@touchstargroup.com> Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/utils/e2fsprogs/Makefile')
-rw-r--r--package/utils/e2fsprogs/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/utils/e2fsprogs/Makefile b/package/utils/e2fsprogs/Makefile
index 9da52d8a2c..247b5ed4a4 100644
--- a/package/utils/e2fsprogs/Makefile
+++ b/package/utils/e2fsprogs/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=e2fsprogs
PKG_VERSION:=1.43.1
PKG_MD5SUM:=1775f3f0eed9dee1c5f39e08d1964a97
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/e2fsprogs