aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/bzip2
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2017-07-05 16:25:23 +0200
committerDaniel Golle <daniel@makrotopia.org>2017-07-05 16:27:40 +0200
commiteb7c14d512482e18d05f61afa44205167ea094c0 (patch)
tree45e1a6705942c54fb2e1571ce1478f9152cd2778 /package/utils/bzip2
parenta0bb6c91fee399fd2008bff571ec77fd57742f27 (diff)
downloadupstream-eb7c14d512482e18d05f61afa44205167ea094c0.tar.gz
upstream-eb7c14d512482e18d05f61afa44205167ea094c0.tar.bz2
upstream-eb7c14d512482e18d05f61afa44205167ea094c0.zip
bzip2: add symlink to binary
Other distributions incl. the OpenWrt ImageBuilder and SDK expect to find the bzip2 executable in /bin. Create a symlink at that location for compatibility. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/utils/bzip2')
-rw-r--r--package/utils/bzip2/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/utils/bzip2/Makefile b/package/utils/bzip2/Makefile
index c17dee136b..62c255a907 100644
--- a/package/utils/bzip2/Makefile
+++ b/package/utils/bzip2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=bzip2
PKG_VERSION:=1.0.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.bzip.org/$(PKG_VERSION)
@@ -82,6 +82,8 @@ endef
define Package/bzip2/install
$(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bzip2-shared $(1)/usr/bin/bzip2
+ $(INSTALL_DIR) $(1)/bin/
+ $(LN) ../usr/bin/bzip2 $(1)/bin/bzip2
endef
HOST_CFLAGS += \