aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/bzip2
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-01-02 00:22:41 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-01-12 22:38:38 +0100
commit6be064c788f5c2edc49c24c9e9c2b48d63a8811c (patch)
treec638672d987d3cd571be26058edc052a0d675be6 /package/utils/bzip2
parente42a227ee3119a8401b1dfe82e51216924b7573a (diff)
downloadupstream-6be064c788f5c2edc49c24c9e9c2b48d63a8811c.tar.gz
upstream-6be064c788f5c2edc49c24c9e9c2b48d63a8811c.tar.bz2
upstream-6be064c788f5c2edc49c24c9e9c2b48d63a8811c.zip
bzip2: fix hardening build
Set the LDFLAGS otherwise it will not get the target hardening flags or any other generic flags provided in the LDFLAGS Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/utils/bzip2')
-rw-r--r--package/utils/bzip2/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/utils/bzip2/Makefile b/package/utils/bzip2/Makefile
index 9b5b824e71..d26e215757 100644
--- a/package/utils/bzip2/Makefile
+++ b/package/utils/bzip2/Makefile
@@ -56,14 +56,14 @@ define Package/bzip2/description
endef
TARGET_CFLAGS += \
- $(FPIC) \
- $(TARGET_LDFLAGS)
+ $(FPIC)
CONFIGURE_ARGS += --prefix=/usr
MAKE_FLAGS += \
-f Makefile-libbz2_so \
CFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="$(TARGET_LDFLAGS)" \
all
define Build/InstallDev
@@ -89,11 +89,11 @@ define Package/bzip2/install
endef
HOST_CFLAGS += \
- $(FPIC) \
- $(HOST_LDFLAGS)
+ $(FPIC)
HOST_MAKE_FLAGS+= \
CFLAGS="$(HOST_CFLAGS)" \
+ LDFLAGS="$(HOST_LDFLAGS)" \
all
HOST_CONFIGURE_ARGS+= \