aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-05-03 00:52:53 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-05-03 00:53:44 +0800
commitfa3649d97ef08b375e628a4875e67f91c6d87644 (patch)
treef57483109b17378e3669b372452c4076d55269dc /package/utils/busybox
parent9b4c41524ffa7ac151f072b8febe05ccc05b529d (diff)
downloadupstream-fa3649d97ef08b375e628a4875e67f91c6d87644.tar.gz
upstream-fa3649d97ef08b375e628a4875e67f91c6d87644.tar.bz2
upstream-fa3649d97ef08b375e628a4875e67f91c6d87644.zip
busybox: add alternatives specs for those also provided by procps-ng
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/utils/busybox')
-rw-r--r--package/utils/busybox/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index b6091bfcd7..a3012da7d4 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.26.2
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -44,7 +44,19 @@ define Package/busybox
URL:=http://busybox.net/
DEPENDS:=+BUSYBOX_USE_LIBRPC:librpc +BUSYBOX_CONFIG_PAM:libpam +BUSYBOX_CONFIG_NTPD:jsonfilter
MENU:=1
- ALTERNATIVES:=100:/sbin/ip:/bin/busybox
+ ALTERNATIVES:=\
+ $(if $(CONFIG_BUSYBOX_DEFAULT_KILL), 100:/bin/kill:/bin/busybox) \
+ $(if $(CONFIG_BUSYBOX_DEFAULT_PS), 100:/bin/ps:/bin/busybox) \
+ $(if $(CONFIG_BUSYBOX_DEFAULT_WATCH), 100:/bin/watch:/bin/busybox) \
+ $(if $(CONFIG_BUSYBOX_DEFAULT_IP), 100:/sbin/ip:/bin/busybox) \
+ $(if $(CONFIG_BUSYBOX_DEFAULT_FREE), 100:/usr/bin/free:/bin/busybox) \
+ $(if $(CONFIG_BUSYBOX_DEFAULT_PGREP), 100:/usr/bin/pgrep:/bin/busybox) \
+ $(if $(CONFIG_BUSYBOX_DEFAULT_PKILL), 100:/usr/bin/pkill:/bin/busybox) \
+ $(if $(CONFIG_BUSYBOX_DEFAULT_PMAP), 100:/usr/bin/pmap:/bin/busybox) \
+ $(if $(CONFIG_BUSYBOX_DEFAULT_PWDX), 100:/usr/bin/pwdx:/bin/busybox) \
+ $(if $(CONFIG_BUSYBOX_DEFAULT_TOP), 100:/usr/bin/top:/bin/busybox) \
+ $(if $(CONFIG_BUSYBOX_DEFAULT_UPTIME), 100:/usr/bin/uptime:/bin/busybox) \
+
endef
define Package/busybox/description