aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2020-01-01 14:34:11 +0100
committerJohn Crispin <john@phrozen.org>2020-01-15 19:57:27 +0100
commitf704f97e4c57e3f2db1bd2f5c87e1e44aebba42b (patch)
tree043e1b7794a1d2ab9a55cfa42fa19c1ebad0216f /package/utils/busybox
parent2248df303def0a9a93467b05288acd3b51da1d75 (diff)
downloadupstream-f704f97e4c57e3f2db1bd2f5c87e1e44aebba42b.tar.gz
upstream-f704f97e4c57e3f2db1bd2f5c87e1e44aebba42b.tar.bz2
upstream-f704f97e4c57e3f2db1bd2f5c87e1e44aebba42b.zip
busybox: Include hdparm by default on nas type device
NAS devices certainly need to have hdparm to configure things like spin-down time or their disks will be constantly spinning. Just catenate CONFIG_HDPARM=y on these configs. Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
Diffstat (limited to 'package/utils/busybox')
-rw-r--r--package/utils/busybox/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index c0f3007e5d..9af0f4853e 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -92,6 +92,9 @@ ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
endif
define Build/Configure
+ifeq ($(DEVICE_TYPE),nas)
+ echo "CONFIG_HDPARM=y" >> $(PKG_BUILD_DIR)/.config
+endif
grep 'CONFIG_BUSYBOX_$(BUSYBOX_SYM)' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_$(BUSYBOX_SYM)_\\(.*\\),\\1CONFIG_\\2,g" > $(PKG_BUILD_DIR)/.config
yes 'n' | $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS) oldconfig
endef