aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-04-25 14:03:11 +0200
committerJo-Philipp Wich <jo@mein.io>2017-04-27 10:44:28 +0200
commitf1e32854619c09a49d85f5066517e300130cbcd2 (patch)
tree3c78fab0a3f75fbc5fb684b0866018e043535e98 /package/utils/busybox
parent3a2cc2c8ad0abe72070688348d70c8d3aadc46ef (diff)
downloadupstream-f1e32854619c09a49d85f5066517e300130cbcd2.tar.gz
upstream-f1e32854619c09a49d85f5066517e300130cbcd2.tar.bz2
upstream-f1e32854619c09a49d85f5066517e300130cbcd2.zip
busybox: nslookup_lede: fix compatibility with v1.25
The ":*" optstring syntax was only recently introduced with BusyBox v1.26, older versions need a corresponding hint in the "opt_complementary" variable to denote flag values that should be stored as llist entries. Add the required opt_complementary entry to fix random SIGBUS, SIGILL or SIGSEGV related crashes on BusyBox 1.25.x when attempting to use the "-q" flag of the "nslookup_lede" applet. Ref: https://forum.lede-project.org/t/nslookup-ipv6-in-lede-17-01-1 Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/utils/busybox')
-rw-r--r--package/utils/busybox/Makefile2
-rw-r--r--package/utils/busybox/patches/230-add_nslookup_lede.patch11
2 files changed, 7 insertions, 6 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index c87243b93c..dd81045ebe 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.26.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/utils/busybox/patches/230-add_nslookup_lede.patch b/package/utils/busybox/patches/230-add_nslookup_lede.patch
index 51034e6bc4..f37f4bd879 100644
--- a/package/utils/busybox/patches/230-add_nslookup_lede.patch
+++ b/package/utils/busybox/patches/230-add_nslookup_lede.patch
@@ -1,4 +1,4 @@
-From 2285cd400a10b1bde5472fe1cec3311300ee943c Mon Sep 17 00:00:00 2001
+From 1188f159e0b0a9c07bed835c7313bedf5322a9e3 Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jo@mein.io>
Date: Tue, 14 Mar 2017 22:21:34 +0100
Subject: [PATCH] networking: add LEDE nslookup applet
@@ -12,16 +12,16 @@ and the libresolv primitives to parse received DNS responses.
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
- networking/nslookup_lede.c | 893 +++++++++++++++++++++++++++++++++++++++++++++
- 1 file changed, 893 insertions(+)
+ networking/nslookup_lede.c | 894 +++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 894 insertions(+)
create mode 100644 networking/nslookup_lede.c
diff --git a/networking/nslookup_lede.c b/networking/nslookup_lede.c
new file mode 100644
-index 000000000..6f1f86502
+index 000000000..f3e42d3bb
--- /dev/null
+++ b/networking/nslookup_lede.c
-@@ -0,0 +1,893 @@
+@@ -0,0 +1,894 @@
+/*
+ * nslookup_lede - musl compatible replacement for busybox nslookup
+ *
@@ -760,6 +760,7 @@ index 000000000..6f1f86502
+ applet_long_options = nslookup_longopts;
+#endif
+
++ opt_complementary = "q::";
+ opts = getopt32(argv, "+q:*p:+r:+t:+s",
+ &type_strings, &default_port,
+ &default_retry, &default_timeout);