aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox
diff options
context:
space:
mode:
authorVal Kulkov <val.kulkov@gmail.com>2018-12-20 15:04:43 -0500
committerJo-Philipp Wich <jo@mein.io>2019-01-30 12:30:03 +0100
commited514e7f9ecc557fdddf2e22f3ad372affc1999b (patch)
tree828870f2c1b2372b9a1292d3ee2ced6c1c38e521 /package/utils/busybox
parent4bcf58135210736f2a1603609d2a76b3e188e2ad (diff)
downloadupstream-ed514e7f9ecc557fdddf2e22f3ad372affc1999b.tar.gz
upstream-ed514e7f9ecc557fdddf2e22f3ad372affc1999b.tar.bz2
upstream-ed514e7f9ecc557fdddf2e22f3ad372affc1999b.zip
busybox: keep syslog.conf during sysupgrade
If a user finds that logd is too barebone for their needs and wishes to have more control over syslog, the user presently has an option to enable CONFIG_BUSYBOX_CONFIG_FEATURE_SYSLOG and configure syslog with settings in /etc/syslog.conf. Presently /etc/syslog.conf silently disappears on sysupgrade. This patch prevents such unwanted behaviour if busybox syslog is enabled via CONFIG_BUSYBOX_CONFIG_FEATURE_SYSLOG. Signed-off-by: Val Kulkov <val.kulkov@gmail.com>
Diffstat (limited to 'package/utils/busybox')
-rw-r--r--package/utils/busybox/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 0eaec19938..dbc5dee62c 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -73,6 +73,12 @@ define Package/busybox/config
source "$(SOURCE)/Config.in"
endef
+ifdef CONFIG_BUSYBOX_CONFIG_FEATURE_SYSLOG
+define Package/busybox/conffiles
+/etc/syslog.conf
+endef
+endif
+
# don't create a version string containing the actual timestamp
export KCONFIG_NOTIMESTAMP=1