aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox
diff options
context:
space:
mode:
authorChen Minqiang <ptpt52@gmail.com>2021-05-20 16:34:28 +0800
committerPaul Spooren <mail@aparcar.org>2021-05-21 11:31:46 +0200
commita9ebd3a0ea968c7f28f9c0763089b67610ce1c1b (patch)
treef1717a8c8e0dc9481c1d5dc13eae9d2d5cbea846 /package/utils/busybox
parent622f8ef577095f711e8f6561fe24d18b86133e7e (diff)
downloadupstream-a9ebd3a0ea968c7f28f9c0763089b67610ce1c1b.tar.gz
upstream-a9ebd3a0ea968c7f28f9c0763089b67610ce1c1b.tar.bz2
upstream-a9ebd3a0ea968c7f28f9c0763089b67610ce1c1b.zip
busybox: nslookup applet link with resolv if use glibc
This fixed b36b8b6929c6d6b17edddfb4597cf6a26a991ed0 ("busybox: remove nslookup_lede/openwrt.patch") It is likely dropped by mistake, This add back the changes Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
Diffstat (limited to 'package/utils/busybox')
-rw-r--r--package/utils/busybox/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 1e7d9dd333..32f0d2c755 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -98,6 +98,10 @@ endif
LDLIBS += $(call BUSYBOX_IF_ENABLED,PAM,pam pam_misc pthread)
+ifeq ($(CONFIG_USE_GLIBC),y)
+ LDLIBS += $(call BUSYBOX_IF_ENABLED,NSLOOKUP,resolv)
+endif
+
ifeq ($(BUILD_VARIANT),selinux)
LDLIBS += selinux sepol
endif