aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox
diff options
context:
space:
mode:
authorDaniel F. Dickinson <cshored@thecshore.com>2019-01-02 05:55:30 -0500
committerHans Dedecker <dedeckeh@gmail.com>2019-01-03 22:24:10 +0100
commita54129d8aa62e63d2e1ab483cf67411d144f19d9 (patch)
treeafdda5e2ce9228cc6ed22b89fa73d96989726ca1 /package/utils/busybox
parent08ef53d2fba179c707c2acfd5a1b60a30c43272f (diff)
downloadupstream-a54129d8aa62e63d2e1ab483cf67411d144f19d9.tar.gz
upstream-a54129d8aa62e63d2e1ab483cf67411d144f19d9.tar.bz2
upstream-a54129d8aa62e63d2e1ab483cf67411d144f19d9.zip
busybox: Add ALTERNATIVES for findutils
Currently busybox find and xargs conflict with the versions from findutils package. Fix this by using ALTERNATIVES in busybox and the related findutils (from packages feed) commit. The conflict is due to the binaries being in the the same place in rootfs and opkg not being happy about that. Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_RELEASE increase]
Diffstat (limited to 'package/utils/busybox')
-rw-r--r--package/utils/busybox/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index d73a5882cb..80e8846a56 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.30.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -46,6 +46,7 @@ define Package/busybox
DEPENDS:=+BUSYBOX_USE_LIBRPC:librpc +BUSYBOX_CONFIG_PAM:libpam +BUSYBOX_CONFIG_NTPD:jsonfilter
MENU:=1
ALTERNATIVES:=\
+ $(call BUSYBOX_IF_ENABLED,FIND, 100:/usr/bin/find:/bin/busybox) \
$(call BUSYBOX_IF_ENABLED,FLOCK, 100:/usr/bin/flock:/bin/busybox) \
$(call BUSYBOX_IF_ENABLED,FREE, 100:/usr/bin/free:/bin/busybox) \
$(call BUSYBOX_IF_ENABLED,IP, 100:/sbin/ip:/bin/busybox) \
@@ -58,6 +59,7 @@ define Package/busybox
$(call BUSYBOX_IF_ENABLED,TOP, 100:/usr/bin/top:/bin/busybox) \
$(call BUSYBOX_IF_ENABLED,UPTIME, 100:/usr/bin/uptime:/bin/busybox) \
$(call BUSYBOX_IF_ENABLED,WATCH, 100:/bin/watch:/bin/busybox) \
+ $(call BUSYBOX_IF_ENABLED,XARGS, 100:/usr/bin/xargs:/bin/busybox) \
endef