aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox
diff options
context:
space:
mode:
authorBruno Randolf <br1@einfach.org>2020-11-09 10:43:10 +0000
committerPetr Štetiar <ynezz@true.cz>2020-11-12 18:19:44 +0100
commit7185c5ec7d357897c1379234a00570afe2ee9eff (patch)
tree2a5738a7094f9f91109cf378301a56f0db6a6dd7 /package/utils/busybox
parentdd993e28eff0ee0fed8abf139e280aa04c0626f6 (diff)
downloadupstream-7185c5ec7d357897c1379234a00570afe2ee9eff.tar.gz
upstream-7185c5ec7d357897c1379234a00570afe2ee9eff.tar.bz2
upstream-7185c5ec7d357897c1379234a00570afe2ee9eff.zip
busybox: Let procd respawn cron
On some systems I see the issue that crond dies after a few days. Simply letting procd respawn the process is a simple safety-net. Signed-off-by: Bruno Randolf <br1@einfach.org>
Diffstat (limited to 'package/utils/busybox')
-rw-r--r--package/utils/busybox/Makefile2
-rwxr-xr-xpackage/utils/busybox/files/cron1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 25db4ff387..71bd888c71 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.31.1
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/utils/busybox/files/cron b/package/utils/busybox/files/cron
index ca04a0c170..4efdfa52ca 100755
--- a/package/utils/busybox/files/cron
+++ b/package/utils/busybox/files/cron
@@ -32,6 +32,7 @@ start_service() {
for crontab in /etc/crontabs/*; do
procd_set_param file "$crontab"
done
+ procd_set_param respawn
procd_close_instance
}