aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-07-17 22:24:45 +0000
committerLuka Perkov <luka@openwrt.org>2013-07-17 22:24:45 +0000
commit67f1d364b8fde1247f02eec0a2da108848922665 (patch)
tree19637c58ffe5a8717e97a30099a0faa981945a0d /package/utils/busybox
parentaf9d30f7132ccaa6527c6dd0d3ad4da478b978e2 (diff)
downloadupstream-67f1d364b8fde1247f02eec0a2da108848922665.tar.gz
upstream-67f1d364b8fde1247f02eec0a2da108848922665.tar.bz2
upstream-67f1d364b8fde1247f02eec0a2da108848922665.zip
base-files/busybox: move ntpd init script from base-files to busybox
SVN-Revision: 37383
Diffstat (limited to 'package/utils/busybox')
-rw-r--r--package/utils/busybox/Makefile3
-rwxr-xr-xpackage/utils/busybox/files/ntp31
2 files changed, 33 insertions, 1 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index aed6ddea6b..0b2778ffd9 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.19.4
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -37,6 +37,7 @@ endif
init-y :=
init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
+init-$(CONFIG_BUSYBOX_CONFIG_NTPD) += ntp
init-$(CONFIG_BUSYBOX_CONFIG_TELNETD) += telnet
define Package/busybox
diff --git a/package/utils/busybox/files/ntp b/package/utils/busybox/files/ntp
new file mode 100755
index 0000000000..c40ee76da3
--- /dev/null
+++ b/package/utils/busybox/files/ntp
@@ -0,0 +1,31 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2011 OpenWrt.org
+
+START=98
+
+USE_PROCD=1
+PROG=/usr/sbin/ntpd
+SERVICE_PID_FILE=/var/run/sysntpd.pid
+
+start_service() {
+ local peers
+ local args="-n"
+ local enable_server
+
+ config_load system
+ config_get peers ntp server
+ config_get_bool enable_server ntp enable_server 0
+
+ [ $enable_server -eq 0 -a -z "$peers" ] && return
+
+ procd_open_instance
+ procd_set_param command "$PROG" -n
+ [ $enable_server -ne 0 ] && procd_append_param command -l
+ [ -n "$peers" ] && {
+ local peer
+ for peer in $peers; do
+ procd_append_param command -p $peer
+ done
+ }
+ procd_close_instance
+}