aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2019-03-01 18:59:31 +0100
committerHans Dedecker <dedeckeh@gmail.com>2019-03-11 17:03:17 +0100
commit2cd28c9a0836b82c591cccc3d9e01228b7990869 (patch)
tree72106b36f3144f09369945c8390babfbd2826cc1 /package/utils/busybox
parentb4917fa907ac6c746d00a3b19d5c7ef56bf6213b (diff)
downloadupstream-2cd28c9a0836b82c591cccc3d9e01228b7990869.tar.gz
upstream-2cd28c9a0836b82c591cccc3d9e01228b7990869.tar.bz2
upstream-2cd28c9a0836b82c591cccc3d9e01228b7990869.zip
busybox: add missing install dir
Add missing /usr/sbin install dir fixing : install: cannot create regular file 'build_dir/target-x86_64_musl/busybox-1.30.1/.pkgdir/busybox/usr/sbin/ntpd-hotplug': No such file or directory Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/utils/busybox')
-rw-r--r--package/utils/busybox/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 540a2ef3ba..8ccf4358af 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.30.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -120,6 +120,7 @@ endef
define Package/busybox/install
$(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_CROND),)
$(INSTALL_BIN) ./files/cron $(1)/etc/init.d/cron