aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox/patches
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-03-09 12:19:37 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-03-12 12:49:03 +0100
commitb8d9a064f08614ac6f6b0ec26eab1450cf8b7544 (patch)
treedb1c2dabba2b2320499e7abf4c44cd3117e0c633 /package/utils/busybox/patches
parent61eee1adfbc9433b08b53f44804d4fb8d8d25f38 (diff)
downloadupstream-b8d9a064f08614ac6f6b0ec26eab1450cf8b7544.tar.gz
upstream-b8d9a064f08614ac6f6b0ec26eab1450cf8b7544.tar.bz2
upstream-b8d9a064f08614ac6f6b0ec26eab1450cf8b7544.zip
busybox: remove i386-specific build flags
busybox tries to be smart and passes a number of additional flags to the compiler. Unfortunately, the i386-specific flags break ABI compatiblity with libc. Fixes busybox crashes observed on x86-generic with GCC 7. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'package/utils/busybox/patches')
-rw-r--r--package/utils/busybox/patches/111-i386_no_arch_flags.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/utils/busybox/patches/111-i386_no_arch_flags.patch b/package/utils/busybox/patches/111-i386_no_arch_flags.patch
new file mode 100644
index 0000000000..4560136871
--- /dev/null
+++ b/package/utils/busybox/patches/111-i386_no_arch_flags.patch
@@ -0,0 +1,10 @@
+--- a/arch/i386/Makefile
++++ /dev/null
+@@ -1,7 +0,0 @@
+-# ==========================================================================
+-# Build system
+-# ==========================================================================
+-
+-# -mpreferred-stack-boundary=2 is essential in preventing gcc 4.2.x
+-# from aligning stack to 16 bytes. (Which is gcc's way of supporting SSE).
+-CFLAGS += $(call cc-option,-march=i386 -mpreferred-stack-boundary=2,)