aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox/config/modutils/Config.in
diff options
context:
space:
mode:
authorMagnus Kroken <mkroken@gmail.com>2017-08-23 23:13:34 +0200
committerHans Dedecker <dedeckeh@gmail.com>2017-08-30 22:34:41 +0200
commit89f8a01daba938e77e94ef311233be49c23a7a55 (patch)
tree927ba3ca70a8549b446a565c8f20353b9866a86e /package/utils/busybox/config/modutils/Config.in
parent9adfeccd8415ed7e999855539a5fca9bfc9a3e4b (diff)
downloadupstream-89f8a01daba938e77e94ef311233be49c23a7a55.tar.gz
upstream-89f8a01daba938e77e94ef311233be49c23a7a55.tar.bz2
upstream-89f8a01daba938e77e94ef311233be49c23a7a55.zip
busybox: update to 1.27.2
Refresh patches, delete patches backported from upstream. This fixes ntpd sync issues (ntpd would not sync if the first provided peer address was unreachable). Signed-off-by: Magnus Kroken <mkroken@gmail.com> Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
Diffstat (limited to 'package/utils/busybox/config/modutils/Config.in')
-rw-r--r--package/utils/busybox/config/modutils/Config.in108
1 files changed, 49 insertions, 59 deletions
diff --git a/package/utils/busybox/config/modutils/Config.in b/package/utils/busybox/config/modutils/Config.in
index 5203db8c59..9791af65a0 100644
--- a/package/utils/busybox/config/modutils/Config.in
+++ b/package/utils/busybox/config/modutils/Config.in
@@ -9,9 +9,11 @@ menu "Linux Module Utilities"
config BUSYBOX_CONFIG_MODPROBE_SMALL
bool "Simplified modutils"
default BUSYBOX_DEFAULT_MODPROBE_SMALL
- select BUSYBOX_CONFIG_PLATFORM_LINUX
help
- Simplified modutils.
+ Build smaller (~1.5 kbytes), simplified module tools.
+
+ This option by itself does not enable any applets -
+ you need to select applets individually below.
With this option modprobe does not require modules.dep file
and does not use /etc/modules.conf file.
@@ -32,11 +34,6 @@ config BUSYBOX_CONFIG_MODPROBE_SMALL
Additional module parameters can be stored in
/etc/modules/$module_name files.
- Apart from modprobe, other utilities are also provided:
- - insmod is an alias to modprobe
- - rmmod is an alias to modprobe -r
- - depmod generates modules.dep.bb
-
config BUSYBOX_CONFIG_DEPMOD
bool "depmod"
default BUSYBOX_DEFAULT_DEPMOD
@@ -62,7 +59,6 @@ config BUSYBOX_CONFIG_FEATURE_LSMOD_PRETTY_2_6_OUTPUT
bool "Pretty output"
default BUSYBOX_DEFAULT_FEATURE_LSMOD_PRETTY_2_6_OUTPUT
depends on BUSYBOX_CONFIG_LSMOD && !BUSYBOX_CONFIG_MODPROBE_SMALL
- select BUSYBOX_CONFIG_PLATFORM_LINUX
help
This option makes output format of lsmod adjusted to
the format of module-init-tools for Linux kernel 2.6.
@@ -73,20 +69,6 @@ config BUSYBOX_CONFIG_MODINFO
select BUSYBOX_CONFIG_PLATFORM_LINUX
help
Show information about a Linux Kernel module
-config BUSYBOX_CONFIG_FEATURE_MODPROBE_SMALL_OPTIONS_ON_CMDLINE
- bool "Accept module options on modprobe command line"
- default BUSYBOX_DEFAULT_FEATURE_MODPROBE_SMALL_OPTIONS_ON_CMDLINE
- depends on BUSYBOX_CONFIG_MODPROBE_SMALL
- select BUSYBOX_CONFIG_PLATFORM_LINUX
- help
- Allow insmod and modprobe take module options from command line.
-
-config BUSYBOX_CONFIG_FEATURE_MODPROBE_SMALL_CHECK_ALREADY_LOADED
- bool "Skip loading of already loaded modules"
- default BUSYBOX_DEFAULT_FEATURE_MODPROBE_SMALL_CHECK_ALREADY_LOADED
- depends on BUSYBOX_CONFIG_MODPROBE_SMALL
- help
- Check if the module is already loaded.
config BUSYBOX_CONFIG_MODPROBE
bool "modprobe"
default BUSYBOX_DEFAULT_MODPROBE
@@ -99,7 +81,6 @@ config BUSYBOX_CONFIG_FEATURE_MODPROBE_BLACKLIST
bool "Blacklist support"
default BUSYBOX_DEFAULT_FEATURE_MODPROBE_BLACKLIST
depends on BUSYBOX_CONFIG_MODPROBE && !BUSYBOX_CONFIG_MODPROBE_SMALL
- select BUSYBOX_CONFIG_PLATFORM_LINUX
help
Say 'y' here to enable support for the 'blacklist' command in
modprobe.conf. This prevents the alias resolver to resolve
@@ -115,38 +96,34 @@ config BUSYBOX_CONFIG_RMMOD
comment "Options common to multiple modutils"
+config BUSYBOX_CONFIG_FEATURE_CMDLINE_MODULE_OPTIONS
+ bool "Accept module options on modprobe command line"
+ default BUSYBOX_DEFAULT_FEATURE_CMDLINE_MODULE_OPTIONS
+ depends on BUSYBOX_CONFIG_INSMOD || BUSYBOX_CONFIG_MODPROBE
+ help
+ Allow insmod and modprobe take module options from the applets'
+ command line.
+
+config BUSYBOX_CONFIG_FEATURE_MODPROBE_SMALL_CHECK_ALREADY_LOADED
+ bool "Skip loading of already loaded modules"
+ default BUSYBOX_DEFAULT_FEATURE_MODPROBE_SMALL_CHECK_ALREADY_LOADED
+ depends on BUSYBOX_CONFIG_MODPROBE_SMALL && (BUSYBOX_CONFIG_DEPMOD || BUSYBOX_CONFIG_INSMOD || BUSYBOX_CONFIG_MODPROBE)
+ help
+ Check if the module is already loaded.
+
config BUSYBOX_CONFIG_FEATURE_2_4_MODULES
bool "Support version 2.2/2.4 Linux kernels"
default BUSYBOX_DEFAULT_FEATURE_2_4_MODULES
- depends on BUSYBOX_CONFIG_INSMOD || BUSYBOX_CONFIG_RMMOD || BUSYBOX_CONFIG_LSMOD
- select BUSYBOX_CONFIG_PLATFORM_LINUX
+ depends on (BUSYBOX_CONFIG_INSMOD || BUSYBOX_CONFIG_LSMOD || BUSYBOX_CONFIG_MODPROBE || BUSYBOX_CONFIG_RMMOD) && !BUSYBOX_CONFIG_MODPROBE_SMALL
help
Support module loading for 2.2.x and 2.4.x Linux kernels.
This increases size considerably. Say N unless you plan
to run ancient kernels.
-config BUSYBOX_CONFIG_FEATURE_INSMOD_TRY_MMAP
- bool "Try to load module from a mmap'ed area"
- default BUSYBOX_DEFAULT_FEATURE_INSMOD_TRY_MMAP
- depends on BUSYBOX_CONFIG_INSMOD || BUSYBOX_CONFIG_MODPROBE_SMALL
- select BUSYBOX_CONFIG_PLATFORM_LINUX
- help
- This option causes module loading code to try to mmap
- module first. If it does not work (for example,
- it does not work for compressed modules), module will be read
- (and unpacked if needed) into a memory block allocated by malloc.
-
- The only case when mmap works but malloc does not is when
- you are trying to load a big module on a very memory-constrained
- machine. Malloc will momentarily need 2x as much memory as mmap.
-
- Choosing N saves about 250 bytes of code (on 32-bit x86).
-
config BUSYBOX_CONFIG_FEATURE_INSMOD_VERSION_CHECKING
bool "Enable module version checking"
default BUSYBOX_DEFAULT_FEATURE_INSMOD_VERSION_CHECKING
depends on BUSYBOX_CONFIG_FEATURE_2_4_MODULES && (BUSYBOX_CONFIG_INSMOD || BUSYBOX_CONFIG_MODPROBE)
- select BUSYBOX_CONFIG_PLATFORM_LINUX
help
Support checking of versions for modules. This is used to
ensure that the kernel and module are made for each other.
@@ -155,10 +132,9 @@ config BUSYBOX_CONFIG_FEATURE_INSMOD_KSYMOOPS_SYMBOLS
bool "Add module symbols to kernel symbol table"
default BUSYBOX_DEFAULT_FEATURE_INSMOD_KSYMOOPS_SYMBOLS
depends on BUSYBOX_CONFIG_FEATURE_2_4_MODULES && (BUSYBOX_CONFIG_INSMOD || BUSYBOX_CONFIG_MODPROBE)
- select BUSYBOX_CONFIG_PLATFORM_LINUX
help
By adding module symbols to the kernel symbol table, Oops messages
- occuring within kernel modules can be properly debugged. By enabling
+ occurring within kernel modules can be properly debugged. By enabling
this feature, module symbols will always be added to the kernel symbol
table for proper debugging support. If you are not interested in
Oops messages from kernel modules, say N.
@@ -167,7 +143,6 @@ config BUSYBOX_CONFIG_FEATURE_INSMOD_LOADINKMEM
bool "In kernel memory optimization (uClinux only)"
default BUSYBOX_DEFAULT_FEATURE_INSMOD_LOADINKMEM
depends on BUSYBOX_CONFIG_FEATURE_2_4_MODULES && (BUSYBOX_CONFIG_INSMOD || BUSYBOX_CONFIG_MODPROBE)
- select BUSYBOX_CONFIG_PLATFORM_LINUX
help
This is a special uClinux only memory optimization that lets insmod
load the specified kernel module directly into kernel space, reducing
@@ -178,7 +153,6 @@ config BUSYBOX_CONFIG_FEATURE_INSMOD_LOAD_MAP
bool "Enable insmod load map (-m) option"
default BUSYBOX_DEFAULT_FEATURE_INSMOD_LOAD_MAP
depends on BUSYBOX_CONFIG_FEATURE_2_4_MODULES && BUSYBOX_CONFIG_INSMOD
- select BUSYBOX_CONFIG_PLATFORM_LINUX
help
Enabling this, one would be able to get a load map
output on stdout. This makes kernel module debugging
@@ -189,8 +163,7 @@ config BUSYBOX_CONFIG_FEATURE_INSMOD_LOAD_MAP
config BUSYBOX_CONFIG_FEATURE_INSMOD_LOAD_MAP_FULL
bool "Symbols in load map"
default BUSYBOX_DEFAULT_FEATURE_INSMOD_LOAD_MAP_FULL
- depends on BUSYBOX_CONFIG_FEATURE_INSMOD_LOAD_MAP && !BUSYBOX_CONFIG_MODPROBE_SMALL
- select BUSYBOX_CONFIG_PLATFORM_LINUX
+ depends on BUSYBOX_CONFIG_FEATURE_INSMOD_LOAD_MAP
help
Without this option, -m will only output section
load map. With this option, -m will also output
@@ -200,18 +173,32 @@ config BUSYBOX_CONFIG_FEATURE_CHECK_TAINTED_MODULE
bool "Support tainted module checking with new kernels"
default BUSYBOX_DEFAULT_FEATURE_CHECK_TAINTED_MODULE
depends on (BUSYBOX_CONFIG_LSMOD || BUSYBOX_CONFIG_FEATURE_2_4_MODULES) && !BUSYBOX_CONFIG_MODPROBE_SMALL
- select BUSYBOX_CONFIG_PLATFORM_LINUX
help
Support checking for tainted modules. These are usually binary
only modules that will make the linux-kernel list ignore your
support request.
This option is required to support GPLONLY modules.
+config BUSYBOX_CONFIG_FEATURE_INSMOD_TRY_MMAP
+ bool "Try to load module from a mmap'ed area"
+ default BUSYBOX_DEFAULT_FEATURE_INSMOD_TRY_MMAP
+ depends on (BUSYBOX_CONFIG_INSMOD || BUSYBOX_CONFIG_MODPROBE) && !BUSYBOX_CONFIG_MODPROBE_SMALL
+ help
+ This option causes module loading code to try to mmap
+ module first. If it does not work (for example,
+ it does not work for compressed modules), module will be read
+ (and unpacked if needed) into a memory block allocated by malloc.
+
+ The only case when mmap works but malloc does not is when
+ you are trying to load a big module on a very memory-constrained
+ machine. Malloc will momentarily need 2x as much memory as mmap.
+
+ Choosing N saves about 250 bytes of code (on 32-bit x86).
+
config BUSYBOX_CONFIG_FEATURE_MODUTILS_ALIAS
- bool "Support for module.aliases file"
+ bool "Support module.aliases file"
default BUSYBOX_DEFAULT_FEATURE_MODUTILS_ALIAS
- depends on BUSYBOX_CONFIG_DEPMOD || BUSYBOX_CONFIG_MODPROBE
- select BUSYBOX_CONFIG_PLATFORM_LINUX
+ depends on (BUSYBOX_CONFIG_DEPMOD || BUSYBOX_CONFIG_MODPROBE) && !BUSYBOX_CONFIG_MODPROBE_SMALL
help
Generate and parse modules.alias containing aliases for bus
identifiers:
@@ -225,10 +212,9 @@ config BUSYBOX_CONFIG_FEATURE_MODUTILS_ALIAS
Say Y if unsure.
config BUSYBOX_CONFIG_FEATURE_MODUTILS_SYMBOLS
- bool "Support for module.symbols file"
+ bool "Support module.symbols file"
default BUSYBOX_DEFAULT_FEATURE_MODUTILS_SYMBOLS
- depends on BUSYBOX_CONFIG_DEPMOD || BUSYBOX_CONFIG_MODPROBE
- select BUSYBOX_CONFIG_PLATFORM_LINUX
+ depends on (BUSYBOX_CONFIG_DEPMOD || BUSYBOX_CONFIG_MODPROBE) && !BUSYBOX_CONFIG_MODPROBE_SMALL
help
Generate and parse modules.symbols containing aliases for
symbol_request() kernel calls, such as:
@@ -239,7 +225,7 @@ config BUSYBOX_CONFIG_FEATURE_MODUTILS_SYMBOLS
config BUSYBOX_CONFIG_DEFAULT_MODULES_DIR
string "Default directory containing modules"
default BUSYBOX_DEFAULT_DEFAULT_MODULES_DIR
- depends on BUSYBOX_CONFIG_DEPMOD || BUSYBOX_CONFIG_MODPROBE || BUSYBOX_CONFIG_MODPROBE_SMALL || BUSYBOX_CONFIG_MODINFO
+ depends on BUSYBOX_CONFIG_DEPMOD || BUSYBOX_CONFIG_MODPROBE || BUSYBOX_CONFIG_MODINFO
help
Directory that contains kernel modules.
Defaults to "/lib/modules"
@@ -247,9 +233,13 @@ config BUSYBOX_CONFIG_DEFAULT_MODULES_DIR
config BUSYBOX_CONFIG_DEFAULT_DEPMOD_FILE
string "Default name of modules.dep"
default BUSYBOX_DEFAULT_DEFAULT_DEPMOD_FILE
- depends on BUSYBOX_CONFIG_DEPMOD || BUSYBOX_CONFIG_MODPROBE || BUSYBOX_CONFIG_MODPROBE_SMALL || BUSYBOX_CONFIG_MODINFO
+ depends on BUSYBOX_CONFIG_DEPMOD || BUSYBOX_CONFIG_MODPROBE || BUSYBOX_CONFIG_MODINFO
help
Filename that contains kernel modules dependencies.
- Defaults to "modules.dep"
+ Defaults to "modules.dep".
+ If you configured the "simplified modutils" (MODPROBE_SMALL), a
+ ".bb" suffix will be added after this name. Do not specify ".bb"
+ here unless you intend your depmod or modprobe to work on
+ "modules.dep.bb.bb" or such.
endmenu