aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox/Makefile
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-09-07 19:29:25 +0000
committerSteven Barth <cyrus@openwrt.org>2015-09-07 19:29:25 +0000
commitd196b1fc2eddf7cbab4351452b6fc9b41f15b142 (patch)
treeff881e04c6d2fbcd087a4b16ce3168099e59af04 /package/utils/busybox/Makefile
parentb850e1e59f5fff02e5719b6b196309f00d600304 (diff)
downloadupstream-d196b1fc2eddf7cbab4351452b6fc9b41f15b142.tar.gz
upstream-d196b1fc2eddf7cbab4351452b6fc9b41f15b142.tar.bz2
upstream-d196b1fc2eddf7cbab4351452b6fc9b41f15b142.zip
Disable telnet in favor of passwordless SSH
This enables passworldless login for root via SSH whenever no root password is set (e.g. after reset, flashing without keeping config or in failsafe) and removes telnet support alltogether. Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 46809
Diffstat (limited to 'package/utils/busybox/Makefile')
-rw-r--r--package/utils/busybox/Makefile1
1 files changed, 0 insertions, 1 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 9571d48bec..a65f44f8fe 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -110,7 +110,6 @@ define Package/busybox/install
$(INSTALL_DIR) $(1)/etc/init.d
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
$(INSTALL_BIN) ./files/cron $(1)/etc/init.d/cron
- $(INSTALL_BIN) ./files/telnet $(1)/etc/init.d/telnet
$(INSTALL_BIN) ./files/sysntpd $(1)/etc/init.d/sysntpd
$(INSTALL_BIN) ./files/ntpd-hotplug $(1)/usr/sbin/ntpd-hotplug
-rm -rf $(1)/lib64