aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox/Makefile
diff options
context:
space:
mode:
authorMikael Magnusson <mikma@users.sourceforge.net>2019-05-27 22:48:10 +0200
committerHans Dedecker <dedeckeh@gmail.com>2019-05-28 13:18:58 +0200
commit8128a7e4fc2d83ed3e20fdb2ad868b1dedd2be4e (patch)
tree2346a388558e1b3397517f7e52d25f550f747fd0 /package/utils/busybox/Makefile
parentb97d44af670e7d9113acc7ba627495411b33cbb8 (diff)
downloadupstream-8128a7e4fc2d83ed3e20fdb2ad868b1dedd2be4e.tar.gz
upstream-8128a7e4fc2d83ed3e20fdb2ad868b1dedd2be4e.tar.bz2
upstream-8128a7e4fc2d83ed3e20fdb2ad868b1dedd2be4e.zip
busybox: fix: ip addr flush hangs when run by non-root user
Add upstream patch from: https://git.busybox.net/busybox/commit/?id=028c5aa18b5273c029f0278232d922ee1a164de6 The patch fixes a problem with an infinite loop causing 100% CPU usage when running the following command /lib/preinit/10_indicate_preinit without the CAP_NET_ADMIN capability (such as in Docker): ip -4 address flush dev $pi_ifname Signed-off-by: Mikael Magnusson <mikma@users.sourceforge.net> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [refresh patch]
Diffstat (limited to 'package/utils/busybox/Makefile')
-rw-r--r--package/utils/busybox/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 8ccf4358af..ff25a35b6e 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.30.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2