aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/adb
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2018-05-25 11:43:32 -0300
committerJohn Crispin <john@phrozen.org>2018-08-01 11:44:30 +0200
commitf63f20fb93c7e67775cb01d97fc88b5b29452b81 (patch)
tree2fc4ca93a3192746ff3ddf2bae0a55b8f2612fe3 /package/utils/adb
parentf30583c41d37c39d3ca063b31871a3c207734b1f (diff)
downloadupstream-f63f20fb93c7e67775cb01d97fc88b5b29452b81.tar.gz
upstream-f63f20fb93c7e67775cb01d97fc88b5b29452b81.tar.bz2
upstream-f63f20fb93c7e67775cb01d97fc88b5b29452b81.zip
adb: added patch for openssl 1.1.0 compatibility
Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'package/utils/adb')
-rw-r--r--package/utils/adb/Makefile2
-rw-r--r--package/utils/adb/patches/010-openssl-1.1.patch28
2 files changed, 29 insertions, 1 deletions
diff --git a/package/utils/adb/Makefile b/package/utils/adb/Makefile
index c42c94d3a3..55f9c1a598 100644
--- a/package/utils/adb/Makefile
+++ b/package/utils/adb/Makefile
@@ -3,7 +3,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=adb
PKG_VERSION:=android.5.0.2_r1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://android.googlesource.com/platform/system/core
diff --git a/package/utils/adb/patches/010-openssl-1.1.patch b/package/utils/adb/patches/010-openssl-1.1.patch
new file mode 100644
index 0000000000..e4df372a34
--- /dev/null
+++ b/package/utils/adb/patches/010-openssl-1.1.patch
@@ -0,0 +1,28 @@
+--- a/adb/adb_auth_host.c
++++ b/adb/adb_auth_host.c
+@@ -83,7 +83,13 @@ static int RSA_to_RSAPublicKey(RSA *rsa,
+ }
+
+ BN_set_bit(r32, 32);
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L
++ const BIGNUM *rsa_n, *rsa_e;
++ RSA_get0_key(rsa, &rsa_n, &rsa_e, NULL);
++ BN_copy(n, rsa_n);
++#else
+ BN_copy(n, rsa->n);
++#endif
+ BN_set_bit(r, RSANUMWORDS * 32);
+ BN_mod_sqr(rr, r, n, ctx);
+ BN_div(NULL, rem, n, r32, ctx);
+@@ -97,7 +103,11 @@ static int RSA_to_RSAPublicKey(RSA *rsa,
+ BN_div(n, rem, n, r32, ctx);
+ pkey->n[i] = BN_get_word(rem);
+ }
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L
++ pkey->exponent = BN_get_word(rsa_e);
++#else
+ pkey->exponent = BN_get_word(rsa->e);
++#endif
+
+ out:
+ BN_free(n0inv);