aboutsummaryrefslogtreecommitdiffstats
path: root/package/util-linux/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-07-04 11:20:46 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-07-04 11:20:46 +0000
commit37a404a6e8d957a61b8beae5957844fec213b2a2 (patch)
tree4afd73debf816af53888ad23a43a6513bcb829a4 /package/util-linux/Makefile
parent31ea6879d75068d42d0f4c77c7e23ea5a6f81d3d (diff)
downloadupstream-37a404a6e8d957a61b8beae5957844fec213b2a2.tar.gz
upstream-37a404a6e8d957a61b8beae5957844fec213b2a2.tar.bz2
upstream-37a404a6e8d957a61b8beae5957844fec213b2a2.zip
Package the hardware clock utility and fix english typos (#2015)
SVN-Revision: 7874
Diffstat (limited to 'package/util-linux/Makefile')
-rw-r--r--package/util-linux/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/package/util-linux/Makefile b/package/util-linux/Makefile
index 43d7f7fb92..f624e92ccc 100644
--- a/package/util-linux/Makefile
+++ b/package/util-linux/Makefile
@@ -31,7 +31,7 @@ define Package/fdisk
$(call Package/util-linux/Default)
TITLE:=Partition table manipulation utility
DESCRIPTION:=\
- This package contains an utility for managing disk partition tables.
+ This package contains a utility for managing disk partition tables.
URL:=http://www.kernel.org/pub/linux/utils/util-linux/
endef
@@ -40,7 +40,7 @@ define Package/cfdisk
TITLE:=Partition table manipulation utility
DEPENDS:=+libncurses
DESCRIPTION:=\
- This package contains an utility for managing disk partition tables.
+ This package contains a utility for managing disk partition tables.
URL:=http://www.kernel.org/pub/linux/utils/util-linux/
endef
@@ -48,7 +48,7 @@ define Package/losetup
$(call Package/util-linux/Default)
TITLE:=Loopback devices setup and control utility
DESCRIPTION:=\
- This package contains an utility for managing loopback devices.
+ This package contains a utility for managing loopback devices.
endef
define Package/swap-utils
@@ -61,6 +61,13 @@ define Package/swap-utils
- swapoff
endef
+define Package/hwclock
+ $(call Package/util-linux/Default)
+ TITLE:=Utilities for managing the hardware clock
+ DESCRIPTION:=\
+ This package contains a utility for managing the hardware clock
+endef
+
TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
define Build/Compile
$(call Build/Compile/Default, \
@@ -98,7 +105,12 @@ define Package/swap-utils/install
$(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
endef
+define Package/hwclock/install
+ $(call Package/Template,sbin/hwclock,$(1)/usr/sbin)
+endef
+
$(eval $(call BuildPackage,fdisk))
$(eval $(call BuildPackage,cfdisk))
$(eval $(call BuildPackage,losetup))
$(eval $(call BuildPackage,swap-utils))
+$(eval $(call BuildPackage,hwclock))