aboutsummaryrefslogtreecommitdiffstats
path: root/package/uhttpd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-06-12 10:16:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-06-12 10:16:47 +0000
commitef014bedf5d6467cbbefd66edc48288619cf8444 (patch)
tree98cbf6dd7a1275ef0d4d903eb9a25509cdcce740 /package/uhttpd
parentf3f8530f81aa560fa5ed7f5aa19e0e23b2e99159 (diff)
downloadupstream-ef014bedf5d6467cbbefd66edc48288619cf8444.tar.gz
upstream-ef014bedf5d6467cbbefd66edc48288619cf8444.tar.bz2
upstream-ef014bedf5d6467cbbefd66edc48288619cf8444.zip
AA: uhttpd: fix build error with the new json-c (#13690)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36924 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uhttpd')
-rw-r--r--package/uhttpd/patches/100-json_c.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/uhttpd/patches/100-json_c.patch b/package/uhttpd/patches/100-json_c.patch
new file mode 100644
index 0000000000..06671fc513
--- /dev/null
+++ b/package/uhttpd/patches/100-json_c.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -62,10 +62,11 @@ ELSE()
+ MESSAGE(FATAL_ERROR "Invalid TLS provider option, use none|openssl|cyassl")
+ ENDIF()
+
++FIND_LIBRARY(json json-c json)
+ IF(UBUS_SUPPORT)
+ ADD_DEFINITIONS(-DHAVE_UBUS)
+ ADD_LIBRARY(uhttpd_ubus MODULE uhttpd-ubus.c)
+- TARGET_LINK_LIBRARIES(uhttpd_ubus ubox ubus json blobmsg_json)
++ TARGET_LINK_LIBRARIES(uhttpd_ubus ubox ubus ${json} blobmsg_json)
+ SET(PLUGINS ${PLUGINS} uhttpd_ubus)
+ ENDIF()
+