aboutsummaryrefslogtreecommitdiffstats
path: root/package/uhttpd/src/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-25 15:46:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-25 15:46:16 +0000
commit169642253f6861ebe356386428692e93126a9df7 (patch)
treee37d2109b8adb553e746e9a0d705fd0547e0adc5 /package/uhttpd/src/Makefile
parent61326faa6035870a8db702dcf7b6e83cc5676f47 (diff)
downloadupstream-169642253f6861ebe356386428692e93126a9df7.tar.gz
upstream-169642253f6861ebe356386428692e93126a9df7.tar.bz2
upstream-169642253f6861ebe356386428692e93126a9df7.zip
add uhttpd (moved from LuCI trunk)
SVN-Revision: 20428
Diffstat (limited to 'package/uhttpd/src/Makefile')
-rw-r--r--package/uhttpd/src/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/package/uhttpd/src/Makefile b/package/uhttpd/src/Makefile
new file mode 100644
index 0000000000..06d61bdef3
--- /dev/null
+++ b/package/uhttpd/src/Makefile
@@ -0,0 +1,52 @@
+CGI_SUPPORT ?= 1
+LUA_SUPPORT ?= 1
+TLS_SUPPORT ?= 1
+
+CFLAGS ?= -I./lua-5.1.4/src -I./cyassl-1.4.0/include -O0 -ggdb3
+LDFLAGS ?= -L./lua-5.1.4/src -L./cyassl-1.4.0/src/.libs
+
+CFLAGS += -Wall --std=gnu99
+
+OBJ = uhttpd.o uhttpd-file.o uhttpd-utils.o
+LIB = -Wl,--export-dynamic -lcrypt -ldl
+
+TLSLIB =
+LUALIB =
+
+
+world: compile
+
+ifeq ($(CGI_SUPPORT),1)
+ OBJ += uhttpd-cgi.o
+ CFLAGS += -DHAVE_CGI
+endif
+
+ifeq ($(LUA_SUPPORT),1)
+ CFLAGS += -DHAVE_LUA
+ LUALIB = uhttpd_lua.so
+
+ $(LUALIB): uhttpd-lua.c
+ $(CC) $(CFLAGS) $(LDFLAGS) $(FPIC) \
+ -shared -lm -llua -ldl \
+ -o $(LUALIB) uhttpd-lua.c
+endif
+
+ifeq ($(TLS_SUPPORT),1)
+ CFLAGS += -DHAVE_TLS
+ TLSLIB = uhttpd_tls.so
+
+ $(TLSLIB): uhttpd-tls.c
+ $(CC) $(CFLAGS) $(LDFLAGS) $(FPIC) \
+ -shared -lcyassl \
+ -o $(TLSLIB) uhttpd-tls.c
+endif
+
+%.o: %.c
+ $(CC) $(CFLAGS) -c -o $@ $<
+
+compile: $(OBJ) $(TLSLIB) $(LUALIB)
+ $(CC) -o uhttpd $(LDFLAGS) $(LIB) $(OBJ)
+
+clean:
+ rm -f *.o *.so uhttpd
+