aboutsummaryrefslogtreecommitdiffstats
path: root/package/uci/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-07-30 19:25:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-07-30 19:25:08 +0000
commitd5df5453a5daef7099e9be0eb3abd2720a8cfe9f (patch)
tree2f5700b4e3738224e6e077923228f0b609435e26 /package/uci/Makefile
parent0536f2b1245f147fc3b9c7ee12c33a30383d970f (diff)
downloadupstream-d5df5453a5daef7099e9be0eb3abd2720a8cfe9f.tar.gz
upstream-d5df5453a5daef7099e9be0eb3abd2720a8cfe9f.tar.bz2
upstream-d5df5453a5daef7099e9be0eb3abd2720a8cfe9f.zip
nuke uci-sh, it is obsolete and no longer works
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12021 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uci/Makefile')
-rw-r--r--package/uci/Makefile13
1 files changed, 0 insertions, 13 deletions
diff --git a/package/uci/Makefile b/package/uci/Makefile
index 7d6fc8c1f9..1cf6dd842d 100644
--- a/package/uci/Makefile
+++ b/package/uci/Makefile
@@ -37,13 +37,6 @@ define Package/uci
TITLE:=Utility for the Unified Configuration Interface (UCI)
endef
-define Package/uci-sh
- SECTION:=base
- CATEGORY:=Base system
- DEPENDS:=@!PACKAGE_uci
- TITLE:=Old shell/awk implementation of UCI
-endef
-
define Package/libuci-lua
SECTION=libs
CATEGORY=Libraries
@@ -84,11 +77,6 @@ define Package/uci/install
$(CP) ./files/uci/* $(1)/
endef
-define Package/uci-sh/install
- $(INSTALL_DIR) $(1)
- $(CP) ./files/uci-sh/* $(1)/
-endef
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_BUILD_DIR)/uci{,_config}.h $(1)/usr/include
@@ -99,4 +87,3 @@ endef
$(eval $(call BuildPackage,uci))
$(eval $(call BuildPackage,libuci))
$(eval $(call BuildPackage,libuci-lua))
-$(eval $(call BuildPackage,uci-sh))