aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-07-06 10:36:35 +0000
committerJohn Crispin <john@openwrt.org>2011-07-06 10:36:35 +0000
commitb808c1bc03363e4c7e5be7b07e8ab8be550c6ba3 (patch)
treee7b49095a024a96651eb037011504d24080bd965 /package/uboot-lantiq/Makefile
parentc93b5653bc9866cb7700e50e2a2f914bfcfbf677 (diff)
downloadupstream-b808c1bc03363e4c7e5be7b07e8ab8be550c6ba3.tar.gz
upstream-b808c1bc03363e4c7e5be7b07e8ab8be550c6ba3.tar.bz2
upstream-b808c1bc03363e4c7e5be7b07e8ab8be550c6ba3.zip
fix lantiq uboot to build lzma compressed bootloaders for eval kits
SVN-Revision: 27487
Diffstat (limited to 'package/uboot-lantiq/Makefile')
-rw-r--r--package/uboot-lantiq/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/uboot-lantiq/Makefile b/package/uboot-lantiq/Makefile
index 83fa6639bd..f13395f684 100644
--- a/package/uboot-lantiq/Makefile
+++ b/package/uboot-lantiq/Makefile
@@ -112,15 +112,15 @@ endef
define Package/uboot-lantiq-$(BUILD_VARIANT)/install
mkdir -p $(1)
-ifneq ($(findstring flash,$(BUILD_VARIANT)),)
+ifneq ($(findstring ramboot,$(BUILD_VARIANT)),)
dd \
- if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot-bootstrap.bin \
- of=$(1)/u-boot-bootstrap.bin \
+ if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot.bin \
+ of=$(1)/u-boot.bin \
bs=64k conv=sync
else
dd \
- if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot.bin \
- of=$(1)/u-boot.bin \
+ if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot-bootstrap.bin \
+ of=$(1)/u-boot-bootstrap.bin \
bs=64k conv=sync
endif
ifneq ($(findstring ramboot,$(BUILD_VARIANT)),)