aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-ifxmips/files/board
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2009-10-04 21:58:18 +0000
committerJohn Crispin <john@openwrt.org>2009-10-04 21:58:18 +0000
commit546e37654bc064e84ba32bc85f88d7d0d2163561 (patch)
tree5ab16f32e674a228c4ce47428a1e381a3db6e0cc /package/uboot-ifxmips/files/board
parenta70ef0c33764bc8cfc9f27403419a01a9dcebb78 (diff)
downloadupstream-546e37654bc064e84ba32bc85f88d7d0d2163561.tar.gz
upstream-546e37654bc064e84ba32bc85f88d7d0d2163561.tar.bz2
upstream-546e37654bc064e84ba32bc85f88d7d0d2163561.zip
fixes ifxmips uboot compile, adds uart uploadable image and fix for wippies homebox flash
SVN-Revision: 17856
Diffstat (limited to 'package/uboot-ifxmips/files/board')
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/config.mk2
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/flash.c4
2 files changed, 4 insertions, 2 deletions
diff --git a/package/uboot-ifxmips/files/board/ifx/danube/config.mk b/package/uboot-ifxmips/files/board/ifx/danube/config.mk
index e6fcbc6591..88680e14f8 100644
--- a/package/uboot-ifxmips/files/board/ifx/danube/config.mk
+++ b/package/uboot-ifxmips/files/board/ifx/danube/config.mk
@@ -24,7 +24,7 @@
#
# Danube board with MIPS 24Kec CPU core
#boot from ebu
-TEXT_BASE = 0xB0000000
+#TEXT_BASE = 0xB0000000
BOOTSTRAP_TEXT_BASE = 0xB0000000
#boot from ram
diff --git a/package/uboot-ifxmips/files/board/ifx/danube/flash.c b/package/uboot-ifxmips/files/board/ifx/danube/flash.c
index 587c072d18..f8a543dbe6 100644
--- a/package/uboot-ifxmips/files/board/ifx/danube/flash.c
+++ b/package/uboot-ifxmips/files/board/ifx/danube/flash.c
@@ -720,7 +720,9 @@ int flash_erase (flash_info_t *info, int s_first, int s_last)
(*DANUBE_EBU_BUSCON0)|=0x80000000; // disable writing
(*DANUBE_EBU_BUSCON1)|=0x80000000; // disable writing
-
+
+ flash_reset(info); /* Homebox Black with JS28F128J3D75 had trouble reading after erase */
+
printf (" done\n");
return rcode;
}