aboutsummaryrefslogtreecommitdiffstats
path: root/package/toolchain
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-09 15:36:43 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-09 15:36:43 +0000
commit9348998887d5fccfd777a0e5f4faff3b6c3dc85c (patch)
treee247c219214055929c4220297399c9c9a36e7417 /package/toolchain
parent52b030cf1677c3d46ddd44117d41aa2bda5d1437 (diff)
downloadupstream-9348998887d5fccfd777a0e5f4faff3b6c3dc85c.tar.gz
upstream-9348998887d5fccfd777a0e5f4faff3b6c3dc85c.tar.bz2
upstream-9348998887d5fccfd777a0e5f4faff3b6c3dc85c.zip
toolchain: fix libpthread package for musl based toolchains (#12651)
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 35069
Diffstat (limited to 'package/toolchain')
-rw-r--r--package/toolchain/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/toolchain/Makefile b/package/toolchain/Makefile
index 84fc3e6b2f..ec5508a754 100644
--- a/package/toolchain/Makefile
+++ b/package/toolchain/Makefile
@@ -451,6 +451,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
define Package/libpthread/install
$(INSTALL_DIR) $(1)/lib
+ ifneq ($(CONFIG_USE_MUSL),y)
$(CP) \
$(TOOLCHAIN_DIR)/lib/libpthread.so.* \
$(if $(BUILD_LIBGCC),\
@@ -458,6 +459,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(TOOLCHAIN_DIR)/lib/libpthread-$(LIBC_SO_VERSION).so \
) \
$(1)/lib/
+ endif
endef
define Package/libthread-db/install