aboutsummaryrefslogtreecommitdiffstats
path: root/package/tapi_sip/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-02-07 21:47:54 +0000
committerJohn Crispin <john@openwrt.org>2011-02-07 21:47:54 +0000
commite651a9341a241ef5cefc1711d42e3f638aaba9b8 (patch)
tree6597330d9c4e70a48df28970d1b882986961e618 /package/tapi_sip/Makefile
parent0cd254bdee1f2575502e0c4c71e1ca2b7dfc5259 (diff)
downloadupstream-e651a9341a241ef5cefc1711d42e3f638aaba9b8.tar.gz
upstream-e651a9341a241ef5cefc1711d42e3f638aaba9b8.tar.bz2
upstream-e651a9341a241ef5cefc1711d42e3f638aaba9b8.zip
* drop libtapi and tapi_sip (moved to external git) * add build variants to pjsip * split tapi_dev audio driver out of patch into src/
SVN-Revision: 25412
Diffstat (limited to 'package/tapi_sip/Makefile')
-rw-r--r--package/tapi_sip/Makefile41
1 files changed, 0 insertions, 41 deletions
diff --git a/package/tapi_sip/Makefile b/package/tapi_sip/Makefile
deleted file mode 100644
index 7a3d6766ac..0000000000
--- a/package/tapi_sip/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=tapi_sip
-PKG_RELEASE:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/tapi_sip
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=tapi_sip
- DEPENDS:=+libuci +libtapi +pjsip +kmod-lqtapi
-endef
-
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
- $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
-define Build/Compile
- CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS)" \
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS)
-endef
-
-define Package/tapi_sip/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/tapi-sip $(1)/usr/bin/
-
- $(INSTALL_DIR) $(1)/etc/config $(1)/etc/init.d
- $(INSTALL_DATA) ./files/telephony.conf $(1)/etc/config/telephony
- $(INSTALL_BIN) ./files/telephony.init $(1)/etc/init.d/telephony
-endef
-
-$(eval $(call BuildPackage,tapi_sip))