aboutsummaryrefslogtreecommitdiffstats
path: root/package/tapi_sip/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2010-11-03 19:12:34 +0000
committerJohn Crispin <john@openwrt.org>2010-11-03 19:12:34 +0000
commita8b2a07f375edefec242de9f20d4aefafa927517 (patch)
treed15f5bb696bfa9dfd9555788d411e0ba59b99a65 /package/tapi_sip/Makefile
parent72ae8452cda47d6e18e664097a4adbc0eee3fc7b (diff)
downloadupstream-a8b2a07f375edefec242de9f20d4aefafa927517.tar.gz
upstream-a8b2a07f375edefec242de9f20d4aefafa927517.tar.bz2
upstream-a8b2a07f375edefec242de9f20d4aefafa927517.zip
* adds a rewrite of the tapi drivers + sip app. this is the result of lars' gsoc 2010 project, Thanks !
SVN-Revision: 23840
Diffstat (limited to 'package/tapi_sip/Makefile')
-rw-r--r--package/tapi_sip/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/package/tapi_sip/Makefile b/package/tapi_sip/Makefile
new file mode 100644
index 0000000000..7a3d6766ac
--- /dev/null
+++ b/package/tapi_sip/Makefile
@@ -0,0 +1,41 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=tapi_sip
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/tapi_sip
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=tapi_sip
+ DEPENDS:=+libuci +libtapi +pjsip +kmod-lqtapi
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
+ LDFLAGS="$(TARGET_LDFLAGS)" \
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS)
+endef
+
+define Package/tapi_sip/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/tapi-sip $(1)/usr/bin/
+
+ $(INSTALL_DIR) $(1)/etc/config $(1)/etc/init.d
+ $(INSTALL_DATA) ./files/telephony.conf $(1)/etc/config/telephony
+ $(INSTALL_BIN) ./files/telephony.init $(1)/etc/init.d/telephony
+endef
+
+$(eval $(call BuildPackage,tapi_sip))