aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-26 13:42:47 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-26 13:42:47 +0000
commitfd670d27568cb157a5a0620662309cea525a26f2 (patch)
treecd86ef8a4fe453f761633bb91ed93b48e1d8de75 /package/system
parente0f48f8d30e52825ece5c4938d8fe32d5842377d (diff)
downloadupstream-fd670d27568cb157a5a0620662309cea525a26f2.tar.gz
upstream-fd670d27568cb157a5a0620662309cea525a26f2.tar.bz2
upstream-fd670d27568cb157a5a0620662309cea525a26f2.zip
procd: add support for relaying daemon stdio to syslog
Procd enabled init scripts can now specify: procd_set_param stdout 1 procd_set_param stderr 1 ... to relay their respective standard IO streams to the system log. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44547
Diffstat (limited to 'package/system')
-rw-r--r--package/system/procd/Makefile4
-rw-r--r--package/system/procd/files/procd.sh3
2 files changed, 5 insertions, 2 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index f31195910d..ba1077492d 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2015-02-26
+PKG_VERSION:=2015-02-26.1
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=4bccbfa967d756b8c84a62ea4752e936d8545a73
+PKG_SOURCE_VERSION:=9851e517f1c3e55228e2fdde913c9cf0b87a4bc7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
diff --git a/package/system/procd/files/procd.sh b/package/system/procd/files/procd.sh
index be1d888a19..78352c0b76 100644
--- a/package/system/procd/files/procd.sh
+++ b/package/system/procd/files/procd.sh
@@ -143,6 +143,9 @@ _procd_set_param() {
user)
json_add_string "$type" "$1"
;;
+ stdout|stderr)
+ json_add_boolean "$type" "$1"
+ ;;
esac
}