aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2021-05-13 01:25:55 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-05-17 19:02:02 +0200
commit097dc943f1f9b02835c6b249b2a035679da5619f (patch)
tree6e1565485b817ed7bb7ba30488f3a74cd145c298 /package/system
parentf2844a63387db342c9173423c58b6e34e0e027b1 (diff)
downloadupstream-097dc943f1f9b02835c6b249b2a035679da5619f.tar.gz
upstream-097dc943f1f9b02835c6b249b2a035679da5619f.tar.bz2
upstream-097dc943f1f9b02835c6b249b2a035679da5619f.zip
openwrt-keyring: Only copy sign key for snapshots
Instead of adding all public signature keys from the openwrt-keyring repository only add the key which is used to sign the master feeds. If one of the other keys would be compromised this would not affect users of master snapshot builds. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/system')
-rw-r--r--package/system/openwrt-keyring/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/system/openwrt-keyring/Makefile b/package/system/openwrt-keyring/Makefile
index 6f3aa65622..318d42cf92 100644
--- a/package/system/openwrt-keyring/Makefile
+++ b/package/system/openwrt-keyring/Makefile
@@ -3,7 +3,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openwrt-keyring
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/keyring.git
@@ -32,7 +32,8 @@ Build/Compile=
define Package/openwrt-keyring/install
$(INSTALL_DIR) $(1)/etc/opkg/keys/
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/usign/* $(1)/etc/opkg/keys/
+ # Public usign key for unattended snapshot builds
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/usign/b5043e70f9a75cde $(1)/etc/opkg/keys/
endef
$(eval $(call BuildPackage,openwrt-keyring))