aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/ubus
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-12-09 19:42:00 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-12-09 19:42:00 +0000
commit213b1e7105bc4577cff162e1d82eb3be2251ca0a (patch)
tree8e3d21e771dba4f91b086527e1a6a12276a5b733 /package/system/ubus
parent3041fbb4d2afe7b2d0598378b25aac3a7444eb4b (diff)
downloadupstream-213b1e7105bc4577cff162e1d82eb3be2251ca0a.tar.gz
upstream-213b1e7105bc4577cff162e1d82eb3be2251ca0a.tar.bz2
upstream-213b1e7105bc4577cff162e1d82eb3be2251ca0a.zip
ubus: fix various ACL processing problems
Bump ubus to current Git HEAD in order to: * Fix a null pointer access when user ACLs are loaded into memory * Fix wrong permission handling for uid=0, gid!=0 peers * Fix return code for permission defined cases * Fix socket error handling when the server connection dies * Make ACL file path configurable * Remove invalid usages of poll() when using a zero timeout Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 47816
Diffstat (limited to 'package/system/ubus')
-rw-r--r--package/system/ubus/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/system/ubus/Makefile b/package/system/ubus/Makefile
index 3e09191b4b..b9434338fa 100644
--- a/package/system/ubus/Makefile
+++ b/package/system/ubus/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubus
-PKG_VERSION:=2015-11-19
+PKG_VERSION:=2015-12-09
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=http://git.openwrt.org/project/ubus.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=259450f414d8c9ee41896e8e6d6bc57ec00e2b63
+PKG_SOURCE_VERSION:=766d49876f8f877f4846c16864e7f73b5a3917f7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MIRROR_MD5SUM:=
CMAKE_INSTALL:=1