aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/ubox
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-28 11:22:05 +0000
committerJohn Crispin <john@openwrt.org>2013-06-28 11:22:05 +0000
commitb1318530e386827cbf83417cefa89f1d29b28721 (patch)
treedb2b6e94da7caa8d880d1405137fe690b37f58bf /package/system/ubox
parentc4f5b5d0d5d6eefc3324c2234cec3615f50b526f (diff)
downloadupstream-b1318530e386827cbf83417cefa89f1d29b28721.tar.gz
upstream-b1318530e386827cbf83417cefa89f1d29b28721.tar.bz2
upstream-b1318530e386827cbf83417cefa89f1d29b28721.zip
ubox: update to latest git revision
* add pivot root support * add back a /etc/init.d/fstab * add "block mount/umount" support * add anonymous swap/mount support * add auto swap/mount support * fix superflous error when inserting modules * add back jffs2reset/jffs2mark Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37057
Diffstat (limited to 'package/system/ubox')
-rw-r--r--package/system/ubox/Makefile17
-rw-r--r--package/system/ubox/files/fstab.init14
2 files changed, 25 insertions, 6 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index 3db0632077..33bacc7536 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubox
-PKG_VERSION:=2013-06-20
+PKG_VERSION:=2013-06-27
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/ubox.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=1b19fc217e33e9b2fc2fab6f9552da740d03a98a
+PKG_SOURCE_VERSION:=725444ad8dd42a6441499fae5a3e92dc99939cc1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
@@ -39,19 +39,24 @@ endef
define Package/ubox/install
$(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,kmodloader,lsbloader,board} $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,kmodloader,lsbloader,board} $(1)/sbin/
ln -s /sbin/mount_root $(1)/sbin/switch2jffs
+ ln -s /sbin/mount_root $(1)/sbin/jffs2reset
+ ln -s /sbin/mount_root $(1)/sbin/jffs2mark
ln -s /sbin/kmodloader $(1)/usr/sbin/lsmod
ln -s /sbin/kmodloader $(1)/usr/sbin/modinfo
endef
define Package/block-mount/install
- $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block
+ $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/
- $(CP) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
+ $(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
+ $(INSTALL_DATA) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
+
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
ln -s /sbin/block $(1)/usr/sbin/swapon
ln -s /sbin/block $(1)/usr/sbin/swapoff
+
endef
$(eval $(call BuildPackage,ubox))
diff --git a/package/system/ubox/files/fstab.init b/package/system/ubox/files/fstab.init
new file mode 100644
index 0000000000..be49470ef1
--- /dev/null
+++ b/package/system/ubox/files/fstab.init
@@ -0,0 +1,14 @@
+#!/bin/sh /etc/rc.common
+# (C) 2013 openwrt.org
+
+START=40
+
+start() {
+ echo "this file has been obseleted. please call \"/sbin/block mount\" directly"
+ /sbin/block mount
+}
+
+stop() {
+ echo "this file has been obseleted. please call \"/sbin/block umount\" directly"
+ /sbin/block umount
+}