aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/ubox
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
committerJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
commit4ebf19b48fafc8d94e14e4ba779969613b241a6a (patch)
tree9918f890a8915023b49ea30948beb5d048c333fa /package/system/ubox
parent44b1688e6c7b4f16f7165fbd560e1183aef69090 (diff)
downloadupstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.gz
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.bz2
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.zip
packages: clean up the package folder
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37007
Diffstat (limited to 'package/system/ubox')
-rw-r--r--package/system/ubox/Makefile58
-rw-r--r--package/system/ubox/files/mount.hotplug1
2 files changed, 59 insertions, 0 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
new file mode 100644
index 0000000000..3db0632077
--- /dev/null
+++ b/package/system/ubox/Makefile
@@ -0,0 +1,58 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ubox
+PKG_VERSION:=2013-06-20
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://nbd.name/luci2/ubox.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=1b19fc217e33e9b2fc2fab6f9552da740d03a98a
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+CMAKE_INSTALL:=1
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=
+
+PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+
+define Package/ubox
+ SECTION:=base
+ CATEGORY:=Base system
+ DEPENDS:=+ubusd +ubus +libuci +USE_EGLIBC:librt
+ TITLE:=OpenWrt system helper toolbox
+endef
+
+define Package/block-mount
+ SECTION:=base
+ CATEGORY:=Base system
+ TITLE:=Block device mounting and checking
+ DEPENDS:=+ubox
+ MENU:=1
+endef
+
+define Package/ubox/install
+ $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin
+
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,kmodloader,lsbloader,board} $(1)/sbin/
+ ln -s /sbin/mount_root $(1)/sbin/switch2jffs
+ ln -s /sbin/kmodloader $(1)/usr/sbin/lsmod
+ ln -s /sbin/kmodloader $(1)/usr/sbin/modinfo
+endef
+
+define Package/block-mount/install
+ $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block
+
+ $(CP) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
+ ln -s /sbin/block $(1)/usr/sbin/swapon
+ ln -s /sbin/block $(1)/usr/sbin/swapoff
+endef
+
+$(eval $(call BuildPackage,ubox))
+$(eval $(call BuildPackage,block-mount))
diff --git a/package/system/ubox/files/mount.hotplug b/package/system/ubox/files/mount.hotplug
new file mode 100644
index 0000000000..946924e351
--- /dev/null
+++ b/package/system/ubox/files/mount.hotplug
@@ -0,0 +1 @@
+/sbin/block hotplug