aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/rpcd/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2016-12-31 16:13:34 -0800
committerFlorian Fainelli <f.fainelli@gmail.com>2017-01-29 11:51:02 -0800
commitf3c5934981d7a30d122827b30d8bca330ce0fd60 (patch)
treebfb450963266e85eb44da4eb644cf66f69080f50 /package/system/rpcd/Makefile
parent200d932322f3d8c436a67c53f4fbca87f0aab8af (diff)
downloadupstream-f3c5934981d7a30d122827b30d8bca330ce0fd60.tar.gz
upstream-f3c5934981d7a30d122827b30d8bca330ce0fd60.tar.bz2
upstream-f3c5934981d7a30d122827b30d8bca330ce0fd60.zip
rpcd: Explicitly link with lcrypt
Fixes build issues with some toolchains that don't add lcrypt in the default search paths: CMakeFiles/rpcd.dir/session.c.o: In function `rpc_login_test_password': build_dir/target-mipsel-linux-gnu/rpcd-2016-12-03-0577cfc1/session.c:823: undefined reference to `crypt' collect2: error: ld returned 1 exit status Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package/system/rpcd/Makefile')
-rw-r--r--package/system/rpcd/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/system/rpcd/Makefile b/package/system/rpcd/Makefile
index 9da7df85fb..d13f20eab4 100644
--- a/package/system/rpcd/Makefile
+++ b/package/system/rpcd/Makefile
@@ -51,6 +51,8 @@ define Package/rpcd/conffiles
/etc/config/rpcd
endef
+TARGET_LDFLAGS += -lcrypt
+
define Package/rpcd/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/rpcd.init $(1)/etc/init.d/rpcd