aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/procd
diff options
context:
space:
mode:
authorMichal Sojka <sojkam1@fel.cvut.cz>2017-11-03 22:31:42 +0100
committerJohn Crispin <john@phrozen.org>2017-11-03 22:31:42 +0100
commit0e300a3a71264d8938b17f9fb0d5f1ab33a0434a (patch)
treeeb9df139c0ab461dc1ebd42245f11c9983fbdce1 /package/system/procd
parent727ab294d05c3ea2d90c4a44a8a1bf718c381a08 (diff)
downloadupstream-0e300a3a71264d8938b17f9fb0d5f1ab33a0434a.tar.gz
upstream-0e300a3a71264d8938b17f9fb0d5f1ab33a0434a.tar.bz2
upstream-0e300a3a71264d8938b17f9fb0d5f1ab33a0434a.zip
procd: Always tell cmake whether to include seccomp support or not
Without this change, when a user disables seccomp support in .config, procd does not get recompiled unless the package is cleaned manually. It is because when -D option is missing from cmake command line, cmake uses cached value from the previous run where seccomp was enabled. Signed-off-by: Michal Sojka <sojkam1@fel.cvut.cz>
Diffstat (limited to 'package/system/procd')
-rw-r--r--package/system/procd/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 67dcf31d0d..83785abd6f 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -87,9 +87,8 @@ ifdef CONFIG_PACKAGE_procd-ujail
CMAKE_OPTIONS += -DJAIL_SUPPORT=1
endif
-ifdef CONFIG_PACKAGE_procd-seccomp
- CMAKE_OPTIONS += -DSECCOMP_SUPPORT=1 -DUTRACE_SUPPORT=1
-endif
+SECCOMP=$(if $(CONFIG_PACKAGE_procd-seccomp),1,0)
+CMAKE_OPTIONS += -DSECCOMP_SUPPORT=$(SECCOMP) -DUTRACE_SUPPORT=$(SECCOMP)
define Package/procd/install
$(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/functions