aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/opkg
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-10 13:02:33 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-10 13:44:25 +0100
commit9cdf852ae09e8b418d9ab5c462b95742dc2f0fc2 (patch)
tree2e2dd387b5f65fab4d62aa1bc8e2730bb0f8f57c /package/system/opkg
parentf5c649d7c61844d80b78d9fc945aec54bfbd7e44 (diff)
downloadupstream-9cdf852ae09e8b418d9ab5c462b95742dc2f0fc2.tar.gz
upstream-9cdf852ae09e8b418d9ab5c462b95742dc2f0fc2.tar.bz2
upstream-9cdf852ae09e8b418d9ab5c462b95742dc2f0fc2.zip
opkg: drop S/MIME support
It has never been used by default (due to being too bloated), and it is properly replaced by usign (which has been the default for a long time now). Remove this feature to simplify the build system Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/system/opkg')
-rw-r--r--package/system/opkg/Makefile67
1 files changed, 8 insertions, 59 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index cbd731f54c..898d769b2e 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -37,7 +37,7 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
-define Package/opkg/Default
+define Package/opkg
SECTION:=base
CATEGORY:=Base system
TITLE:=opkg package manager
@@ -46,7 +46,7 @@ define Package/opkg/Default
MENU:=1
endef
-define Package/opkg/Default/description
+define Package/opkg/description
Lightweight package management system
opkg is the opkg Package Management System, for handling
installation and removal of packages on a system. It can
@@ -66,47 +66,12 @@ config OPKG_SUPPORT_MD5
Old opkg used md5s, new uses sha. This options enables understanding both while prefering sha.
endef
-define Package/opkg
- $(call Package/opkg/Default)
- VARIANT:=unsigned
-endef
-
-define Package/opkg/description
- $(call Package/opkg/Default/description)
-endef
-
define Package/opkg/conffiles
/etc/opkg.conf
/etc/opkg/keys/
/etc/opkg/customfeeds.conf
endef
-
-define Package/opkg-smime
- $(call Package/opkg/Default)
- TITLE+= (with S/MIME signature support)
- DEPENDS+=+PACKAGE_opkg-smime:libopenssl
- VARIANT:=smime
-endef
-
-define Package/opkg-smime/description
- $(call Package/opkg/Default/description)
-
- This package allows the Package index to be verified with S/MIME.
-endef
-
-define Package/opkg-smime/config
-config OPKG_SMIME_SUPPORT_MD5
- bool
- default n
- depends on PACKAGE_opkg-smime
- prompt "Support reading old md5 hashes."
- help
- Old opkg used md5s, new uses sha. This options enables understanding both while prefering sha.
-endef
-
-Package/opkg-smime/conffiles = $(Package/opkg/conffiles)
-
TARGET_CFLAGS += -ffunction-sections -fdata-sections
EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
@@ -117,22 +82,13 @@ CONFIGURE_ARGS += \
--with-opkgetcdir=/etc \
--with-opkglockfile=/var/lock/opkg.lock
-ifeq ($(BUILD_VARIANT),smime)
- CONFIGURE_ARGS += --enable-openssl --disable-usign
- ifeq ($(CONFIG_OPKG_SMIME_SUPPORT_MD5),y)
- CONFIGURE_ARGS += --enable-md5
- else
- CONFIGURE_ARGS += --disable-md5
- endif
+ifndef CONFIG_SIGNED_PACKAGES
+ CONFIGURE_ARGS += --disable-usign
+endif
+ifeq ($(CONFIG_OPKG_SUPPORT_MD5),y)
+ CONFIGURE_ARGS += --enable-md5
else
- ifndef CONFIG_SIGNED_PACKAGES
- CONFIGURE_ARGS += --disable-usign
- endif
- ifeq ($(CONFIG_OPKG_SUPPORT_MD5),y)
- CONFIGURE_ARGS += --enable-md5
- else
- CONFIGURE_ARGS += --disable-md5
- endif
+ CONFIGURE_ARGS += --disable-md5
endif
MAKE_FLAGS = \
@@ -163,12 +119,6 @@ define Package/opkg/install
$(INSTALL_BIN) ./files/opkg-key $(1)/usr/sbin/
endef
-define Package/opkg-smime/install
- $(call Package/opkg/Default/install,$(1),-smime)
- $(INSTALL_DIR) $(1)/etc/ssl/certs
- $(if $(CONFIG_OPKGSMIME_CERT),$(INSTALL_DATA) $(call qstrip,$(CONFIG_OPKGSMIME_CERT)) $(1)/etc/ssl/certs/opkg.pem,)
-endef
-
define Build/InstallDev
mkdir -p $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/libopkg $(1)/usr/include/
@@ -191,5 +141,4 @@ define Host/Install
endef
$(eval $(call BuildPackage,opkg))
-$(eval $(call BuildPackage,opkg-smime))
$(eval $(call HostBuild))