aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/mtd
diff options
context:
space:
mode:
authorGeorge Hopkins <george-hopkins@null.net>2017-10-28 14:08:38 +0200
committerJohn Crispin <john@phrozen.org>2018-02-13 11:16:49 +0100
commit520335506273ed248074f7b3d2ba8bec148dddaa (patch)
tree367b698bbfc8266a73b67e42d02a140bb42447e9 /package/system/mtd
parent5c7a58764e55d34317db2cfedb7206c634b4d7f6 (diff)
downloadupstream-520335506273ed248074f7b3d2ba8bec148dddaa.tar.gz
upstream-520335506273ed248074f7b3d2ba8bec148dddaa.tar.bz2
upstream-520335506273ed248074f7b3d2ba8bec148dddaa.zip
mtd: add fixwrg command
Add a command to fix WRG headers, based on wrgg.c. Signed-off-by: George Hopkins <george-hopkins@null.net>
Diffstat (limited to 'package/system/mtd')
-rw-r--r--package/system/mtd/src/Makefile1
-rw-r--r--package/system/mtd/src/mtd.c26
-rw-r--r--package/system/mtd/src/mtd.h1
-rw-r--r--package/system/mtd/src/wrg.c208
4 files changed, 233 insertions, 3 deletions
diff --git a/package/system/mtd/src/Makefile b/package/system/mtd/src/Makefile
index 4e39a89315..52fac47fe0 100644
--- a/package/system/mtd/src/Makefile
+++ b/package/system/mtd/src/Makefile
@@ -4,6 +4,7 @@ LDFLAGS += -lubox
obj = mtd.o jffs2.o crc32.o md5.o
obj.seama = seama.o md5.o
+obj.wrg = wrg.o md5.o
obj.wrgg = wrgg.o md5.o
obj.ar71xx = trx.o $(obj.seama) $(obj.wrgg)
obj.brcm = trx.o
diff --git a/package/system/mtd/src/mtd.c b/package/system/mtd/src/mtd.c
index e66e647c01..55a3bdba81 100644
--- a/package/system/mtd/src/mtd.c
+++ b/package/system/mtd/src/mtd.c
@@ -54,6 +54,7 @@
#define TRX_MAGIC 0x48445230 /* "HDR0" */
#define SEAMA_MAGIC 0x5ea3a417
+#define WRG_MAGIC 0x20040220
#define WRGG03_MAGIC 0x20080321
#if !defined(__BYTE_ORDER)
@@ -76,6 +77,7 @@ enum mtd_image_format {
MTD_IMAGE_FORMAT_UNKNOWN,
MTD_IMAGE_FORMAT_TRX,
MTD_IMAGE_FORMAT_SEAMA,
+ MTD_IMAGE_FORMAT_WRG,
MTD_IMAGE_FORMAT_WRGG03,
};
@@ -205,6 +207,8 @@ image_check(int imagefd, const char *mtd)
imageformat = MTD_IMAGE_FORMAT_TRX;
else if (be32_to_cpu(magic) == SEAMA_MAGIC)
imageformat = MTD_IMAGE_FORMAT_SEAMA;
+ else if (le32_to_cpu(magic) == WRG_MAGIC)
+ imageformat = MTD_IMAGE_FORMAT_WRG;
else if (le32_to_cpu(magic) == WRGG03_MAGIC)
imageformat = MTD_IMAGE_FORMAT_WRGG03;
@@ -214,7 +218,7 @@ image_check(int imagefd, const char *mtd)
ret = trx_check(imagefd, mtd, buf, &buflen);
break;
case MTD_IMAGE_FORMAT_SEAMA:
- break;
+ case MTD_IMAGE_FORMAT_WRG:
case MTD_IMAGE_FORMAT_WRGG03:
break;
default:
@@ -685,6 +689,10 @@ resume:
if (mtd_fixseama)
mtd_fixseama(mtd, 0, 0);
break;
+ case MTD_IMAGE_FORMAT_WRG:
+ if (mtd_fixwrg)
+ mtd_fixwrg(mtd, 0, 0);
+ break;
case MTD_IMAGE_FORMAT_WRGG03:
if (mtd_fixwrgg)
mtd_fixwrgg(mtd, 0, 0);
@@ -734,6 +742,10 @@ static void usage(void)
fprintf(stderr,
" fixseama fix the checksum in a seama header on first boot\n");
}
+ if (mtd_fixwrg) {
+ fprintf(stderr,
+ " fixwrg fix the checksum in a wrg header on first boot\n");
+ }
if (mtd_fixwrgg) {
fprintf(stderr,
" fixwrgg fix the checksum in a wrgg header on first boot\n");
@@ -755,9 +767,9 @@ static void usage(void)
fprintf(stderr,
" -o offset offset of the image header in the partition(for fixtrx)\n");
}
- if (mtd_fixtrx || mtd_fixseama || mtd_fixwrgg) {
+ if (mtd_fixtrx || mtd_fixseama || mtd_fixwrg || mtd_fixwrgg) {
fprintf(stderr,
- " -c datasize amount of data to be used for checksum calculation (for fixtrx / fixseama / fixwrgg)\n");
+ " -c datasize amount of data to be used for checksum calculation (for fixtrx / fixseama / fixwrg / fixwrgg)\n");
}
fprintf(stderr,
#ifdef FIS_SUPPORT
@@ -798,6 +810,7 @@ int main (int argc, char **argv)
CMD_JFFS2WRITE,
CMD_FIXTRX,
CMD_FIXSEAMA,
+ CMD_FIXWRG,
CMD_FIXWRGG,
CMD_VERIFY,
CMD_DUMP,
@@ -913,6 +926,9 @@ int main (int argc, char **argv)
} else if (((strcmp(argv[0], "fixseama") == 0) && (argc == 2)) && mtd_fixseama) {
cmd = CMD_FIXSEAMA;
device = argv[1];
+ } else if (((strcmp(argv[0], "fixwrg") == 0) && (argc == 2)) && mtd_fixwrg) {
+ cmd = CMD_FIXWRG;
+ device = argv[1];
} else if (((strcmp(argv[0], "fixwrgg") == 0) && (argc == 2)) && mtd_fixwrgg) {
cmd = CMD_FIXWRGG;
device = argv[1];
@@ -1012,6 +1028,10 @@ int main (int argc, char **argv)
if (mtd_fixseama)
mtd_fixseama(device, 0, data_size);
break;
+ case CMD_FIXWRG:
+ if (mtd_fixwrg)
+ mtd_fixwrg(device, 0, data_size);
+ break;
case CMD_FIXWRGG:
if (mtd_fixwrgg)
mtd_fixwrgg(device, 0, data_size);
diff --git a/package/system/mtd/src/mtd.h b/package/system/mtd/src/mtd.h
index 50a42da14b..0250a90e0b 100644
--- a/package/system/mtd/src/mtd.h
+++ b/package/system/mtd/src/mtd.h
@@ -27,6 +27,7 @@ extern int trx_fixup(int fd, const char *name) __attribute__ ((weak));
extern int trx_check(int imagefd, const char *mtd, char *buf, int *len) __attribute__ ((weak));
extern int mtd_fixtrx(const char *mtd, size_t offset, size_t data_size) __attribute__ ((weak));
extern int mtd_fixseama(const char *mtd, size_t offset, size_t data_size) __attribute__ ((weak));
+extern int mtd_fixwrg(const char *mtd, size_t offset, size_t data_size) __attribute__ ((weak));
extern int mtd_fixwrgg(const char *mtd, size_t offset, size_t data_size) __attribute__ ((weak));
extern int mtd_resetbc(const char *mtd) __attribute__ ((weak));
#endif /* __mtd_h */
diff --git a/package/system/mtd/src/wrg.c b/package/system/mtd/src/wrg.c
new file mode 100644
index 0000000000..879cf1bbe0
--- /dev/null
+++ b/package/system/mtd/src/wrg.c
@@ -0,0 +1,208 @@
+/*
+ * wrg.c
+ *
+ * Copyright (C) 2005 Mike Baker
+ * Copyright (C) 2008 Felix Fietkau <nbd@nbd.name>
+ * Copyright (C) 2011-2012 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (C) 2016 Stijn Tintel <stijn@linux-ipv6.be>
+ * Copyright (C) 2017 George Hopkins <george-hopkins@null.net>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
+#include <byteswap.h>
+#include <endian.h>
+#include <stdio.h>
+#include <stdlib.h>
+#include <stddef.h>
+#include <unistd.h>
+#include <fcntl.h>
+#include <sys/mman.h>
+#include <sys/stat.h>
+#include <string.h>
+#include <errno.h>
+#include <arpa/inet.h>
+
+#include <sys/ioctl.h>
+#include <mtd/mtd-user.h>
+#include "mtd.h"
+#include "md5.h"
+
+#if !defined(__BYTE_ORDER)
+#error "Unknown byte order"
+#endif
+
+#if __BYTE_ORDER == __BIG_ENDIAN
+#define cpu_to_le32(x) bswap_32(x)
+#define le32_to_cpu(x) bswap_32(x)
+#elif __BYTE_ORDER == __LITTLE_ENDIAN
+#define cpu_to_le32(x) (x)
+#define le32_to_cpu(x) (x)
+#else
+#error "Unsupported endianness"
+#endif
+
+#define WRG_MAGIC 0x20040220
+
+struct wrg_header {
+ char signature[32];
+ uint32_t magic1;
+ uint32_t magic2;
+ uint32_t size;
+ uint32_t offset;
+ char devname[32];
+ char digest[16];
+} __attribute__ ((packed));
+
+ssize_t pread(int fd, void *buf, size_t count, off_t offset);
+ssize_t pwrite(int fd, const void *buf, size_t count, off_t offset);
+
+int
+wrg_fix_md5(struct wrg_header *shdr, int fd, size_t data_offset, size_t data_size)
+{
+ char *buf;
+ ssize_t res;
+ MD5_CTX ctx;
+ unsigned char digest[16];
+ int i;
+ int err = 0;
+
+ buf = malloc(data_size);
+ if (!buf) {
+ err = -ENOMEM;
+ goto err_out;
+ }
+
+ res = pread(fd, buf, data_size, data_offset);
+ if (res != data_size) {
+ perror("pread");
+ err = -EIO;
+ goto err_free;
+ }
+
+ MD5_Init(&ctx);
+ MD5_Update(&ctx, (char *)&shdr->offset, sizeof(shdr->offset));
+ MD5_Update(&ctx, (char *)&shdr->devname, sizeof(shdr->devname));
+ MD5_Update(&ctx, buf, data_size);
+ MD5_Final(digest, &ctx);
+
+ if (!memcmp(digest, shdr->digest, sizeof(digest))) {
+ if (quiet < 2)
+ fprintf(stderr, "the header is fixed already\n");
+ return -1;
+ }
+
+ if (quiet < 2) {
+ fprintf(stderr, "new size: %u, new MD5: ", data_size);
+ for (i = 0; i < sizeof(digest); i++)
+ fprintf(stderr, "%02x", digest[i]);
+
+ fprintf(stderr, "\n");
+ }
+
+ /* update the size in the image */
+ shdr->size = cpu_to_le32(data_size);
+
+ /* update the checksum in the image */
+ memcpy(shdr->digest, digest, sizeof(digest));
+
+err_free:
+ free(buf);
+err_out:
+ return err;
+}
+
+int
+mtd_fixwrg(const char *mtd, size_t offset, size_t data_size)
+{
+ int fd;
+ char *first_block;
+ ssize_t res;
+ size_t block_offset;
+ size_t data_offset;
+ struct wrg_header *shdr;
+
+ if (quiet < 2)
+ fprintf(stderr, "Trying to fix WRG header in %s at 0x%x...\n",
+ mtd, offset);
+
+ block_offset = offset & ~(erasesize - 1);
+ offset -= block_offset;
+
+ fd = mtd_check_open(mtd);
+ if(fd < 0) {
+ fprintf(stderr, "Could not open mtd device: %s\n", mtd);
+ exit(1);
+ }
+
+ if (block_offset + erasesize > mtdsize) {
+ fprintf(stderr, "Offset too large, device size 0x%x\n",
+ mtdsize);
+ exit(1);
+ }
+
+ first_block = malloc(erasesize);
+ if (!first_block) {
+ perror("malloc");
+ exit(1);
+ }
+
+ res = pread(fd, first_block, erasesize, block_offset);
+ if (res != erasesize) {
+ perror("pread");
+ exit(1);
+ }
+
+ shdr = (struct wrg_header *)(first_block + offset);
+ if (le32_to_cpu(shdr->magic1) != WRG_MAGIC) {
+ fprintf(stderr, "No WRG header found (%08x != %08x)\n",
+ le32_to_cpu(shdr->magic1), WRG_MAGIC);
+ exit(1);
+ } else if (!le32_to_cpu(shdr->size)) {
+ fprintf(stderr, "WRG entity with empty image\n");
+ exit(1);
+ }
+
+ data_offset = offset + sizeof(struct wrg_header);
+ if (!data_size)
+ data_size = mtdsize - data_offset;
+ if (data_size > le32_to_cpu(shdr->size))
+ data_size = le32_to_cpu(shdr->size);
+ if (wrg_fix_md5(shdr, fd, data_offset, data_size))
+ goto out;
+
+ if (mtd_erase_block(fd, block_offset)) {
+ fprintf(stderr, "Can't erease block at 0x%x (%s)\n",
+ block_offset, strerror(errno));
+ exit(1);
+ }
+
+ if (quiet < 2)
+ fprintf(stderr, "Rewriting block at 0x%x\n", block_offset);
+
+ if (pwrite(fd, first_block, erasesize, block_offset) != erasesize) {
+ fprintf(stderr, "Error writing block (%s)\n", strerror(errno));
+ exit(1);
+ }
+
+ if (quiet < 2)
+ fprintf(stderr, "Done.\n");
+
+out:
+ close (fd);
+ sync();
+
+ return 0;
+}