aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/mtd/src/Makefile
diff options
context:
space:
mode:
authorJeff Kletsky <git-commits@allycomm.com>2019-04-10 08:28:01 -0700
committerChristian Lamparter <chunkeey@gmail.com>2019-05-18 13:43:51 +0200
commitb3770eaca39f223faecfcc0d169a1bb2f6f9464a (patch)
tree4697e1277e06775e1fdf0e36aadbe1f636b22806 /package/system/mtd/src/Makefile
parent4bdc873a5fda60557478a4294983cf71e7eccea6 (diff)
downloadupstream-b3770eaca39f223faecfcc0d169a1bb2f6f9464a.tar.gz
upstream-b3770eaca39f223faecfcc0d169a1bb2f6f9464a.tar.bz2
upstream-b3770eaca39f223faecfcc0d169a1bb2f6f9464a.zip
mtd: base-files: Unify dual-firmware devices (Linksys)
Consistently handle boot-count reset and upgrade across ipq40xx, ipq806x, kirkwood, mvebu Dual-firmware devices often utilize a specific MTD partition to record the number of times the boot loader has initiated boot. Most of these devices are NAND, typically with a 2k erase size. When this code was ported to the ipq40xx platform, the device in hand used NOR for this partition, with a 16-byte "record" size. As the implementation of `mtd resetbc` is by-platform, the hard-coded nature of this change prevented proper operation of a NAND-based device. * Unified the "NOR" variant with the rest of the Linksys variants * Added logging to indicate success and failure * Provided a meaningful return value for scripting * "Protected" the use of `mtd resetbc` in start-up scripts so that failure does not end the boot sequence * Moved Linksys-specific actions into common `/etc/init.d/bootcount` For upgrade, these devices need to determine which partition to flash, as well as set certain U-Boot envirnment variables to change the next boot to the newly flashed version. * Moved upgrade-related environment changes out of bootcount * Combined multiple flashes of environment into single one * Current-partition detection now handles absence of `boot_part` Runtime-tested: Linksys EA8300 Signed-off-by: Jeff Kletsky <git-commits@allycomm.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [checkpatch.pl fixes, traded split strings for 80+ chars per line]
Diffstat (limited to 'package/system/mtd/src/Makefile')
-rw-r--r--package/system/mtd/src/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/system/mtd/src/Makefile b/package/system/mtd/src/Makefile
index 08a9fb295d..e469e23ef7 100644
--- a/package/system/mtd/src/Makefile
+++ b/package/system/mtd/src/Makefile
@@ -16,7 +16,7 @@ obj.ramips = $(obj.seama) $(obj.tpl) $(obj.wrg)
obj.mvebu = linksys_bootcount.o
obj.kirkwood = linksys_bootcount.o
obj.ipq806x = linksys_bootcount.o
-obj.ipq40xx = linksys_bootcount_fix.o
+obj.ipq40xx = linksys_bootcount.o
ifdef FIS_SUPPORT
obj += fis.o