aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/mtd/Makefile
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-12-31 16:24:25 +0100
committerMathias Kresin <dev@kresin.me>2019-01-26 21:46:32 +0100
commit1e06482f7db284567b240ce6f59c644439ec813f (patch)
tree6671fac8711f91e3b37c746f6d4b9b6b6199cd90 /package/system/mtd/Makefile
parent36a091cb076dda891e3b41ae3080f858f88697c3 (diff)
downloadupstream-1e06482f7db284567b240ce6f59c644439ec813f.tar.gz
upstream-1e06482f7db284567b240ce6f59c644439ec813f.tar.bz2
upstream-1e06482f7db284567b240ce6f59c644439ec813f.zip
mtd: add logic for TP-Link ramips recovery magic
This adds an option to set the recovery flag of newer TP-Link MediaTek boards and remove it after a successful write. To make use of this feature, add the '-t' option to mtd-write. The '-t' option takes the mtd partition containing the recovery flag (usually 'romfile') as an argument. Make sure this partition is not flagged as read-only! Example: > mtd -t romfile write owrt.bin firmware This command writes the recovery-flag before it begins writing the image to the firmware partition. After the image-write has been successful, the recovery flag is removed. This way, the TP-Link web-recovery is automatically enabled on an unsucessful flash (e.g. power loss). This option is only available if the mtd package is compiled for the ramips target. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'package/system/mtd/Makefile')
-rw-r--r--package/system/mtd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/system/mtd/Makefile b/package/system/mtd/Makefile
index 65de47f23f..c307555436 100644
--- a/package/system/mtd/Makefile
+++ b/package/system/mtd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mtd
-PKG_RELEASE:=23
+PKG_RELEASE:=24
PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
STAMP_PREPARED := $(STAMP_PREPARED)_$(call confvar,CONFIG_MTD_REDBOOT_PARTS)