aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/iucode-tool
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2018-02-11 12:30:07 +0100
committerZoltan HERPAI <wigyori@uid0.hu>2018-02-11 14:39:16 +0100
commitd3da2fcb8b93387d844eb2a47542154383857dd5 (patch)
tree63bd0ba517849dba3370894ff22367320a3983bc /package/system/iucode-tool
parent72d949e7ba3474759af799ecd0c6fee2f70c59be (diff)
downloadupstream-d3da2fcb8b93387d844eb2a47542154383857dd5.tar.gz
upstream-d3da2fcb8b93387d844eb2a47542154383857dd5.tar.bz2
upstream-d3da2fcb8b93387d844eb2a47542154383857dd5.zip
tools: add iucode-tool
Add tool to "compile" Intel microcode files. The tool will be compiled for host (to split the microcode.dat) and for target (to forcibly reload the microcode if required). Instead of using the large microcode.bin/microcode-64.bin, the splitted ucode files (separate for CPU families) will be installed. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'package/system/iucode-tool')
-rw-r--r--package/system/iucode-tool/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/package/system/iucode-tool/Makefile b/package/system/iucode-tool/Makefile
new file mode 100644
index 0000000000..5f4cfb6238
--- /dev/null
+++ b/package/system/iucode-tool/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2018 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=iucode-tool
+PKG_VERSION:=2.3.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=iucode-tool_$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://gitlab.com/iucode-tool/releases/raw/latest
+PKG_HASH:=12b88efa4d0d95af08db05a50b3dcb217c0eb2bfc67b483779e33d498ddb2f95
+
+PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone USE_MUSL:argp-standalone
+
+PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
+PKG_LICENSE:=GPL-2.0
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+
+define Package/iucode-tool
+ SECTION:=utils
+ CATEGORY:=Base system
+ URL:=$(PKG_SOURCE_URL)
+ DEPENDS:=@TARGET_x86
+ TITLE:=Intel microcode loader
+endef
+
+define Package/iucode-tool/install
+ $(INSTALL_DIR) $(1)/lib/firmware
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/iucode_tool $(1)/usr/bin/
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/iucode_tool $(STAGING_DIR_HOST)/bin/iucode_tool
+endef
+
+$(eval $(call HostBuild))
+$(eval $(call BuildPackage,iucode-tool))