aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/ca-certificates
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2018-07-05 18:51:54 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-07-07 18:19:39 +0200
commit191078e83d127f5ed9a38366d2edaac49f9333c5 (patch)
treef269c036e29da868b83a95b87c5f1d471e36ec59 /package/system/ca-certificates
parent9f451ec698ede068e911821473cbe94f50a2977c (diff)
downloadupstream-191078e83d127f5ed9a38366d2edaac49f9333c5.tar.gz
upstream-191078e83d127f5ed9a38366d2edaac49f9333c5.tar.bz2
upstream-191078e83d127f5ed9a38366d2edaac49f9333c5.zip
ca-certificates: ca-bundle: add symlink for openssl default setting
OpenSSL defaults X509_CERT_FILE to /etc/ssl/cert.pem. This change is needed for wget-ssl and possibly others to work seamlessly with fresh ca-bundle installation Fixes openwrt/packages#6152 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/system/ca-certificates')
-rw-r--r--package/system/ca-certificates/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/system/ca-certificates/Makefile b/package/system/ca-certificates/Makefile
index 537cf2f4e9..6de00b7161 100644
--- a/package/system/ca-certificates/Makefile
+++ b/package/system/ca-certificates/Makefile
@@ -8,6 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ca-certificates
PKG_VERSION:=20180409
+PKG_RELEASE:=2
PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.xz
@@ -57,6 +58,7 @@ endef
define Package/ca-bundle/install
$(INSTALL_DIR) $(1)/etc/ssl/certs
cat $(PKG_INSTALL_DIR)/usr/share/ca-certificates/*/*.crt >$(1)/etc/ssl/certs/ca-certificates.crt
+ $(LN) /etc/ssl/certs/ca-certificates.crt $(1)/etc/ssl/cert.pem
endef
$(eval $(call BuildPackage,ca-certificates))
$(eval $(call BuildPackage,ca-bundle))