aboutsummaryrefslogtreecommitdiffstats
path: root/package/swconfig/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-21 18:48:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-21 18:48:48 +0000
commit2fe9c95f5bea76b5e716cf28d1daefc9adf2ecb0 (patch)
treeb1f9a7a7a9a8219b671876302e4b8b31257e06dc /package/swconfig/Makefile
parent51966a3107ba86a389d275dae567b443a97586ad (diff)
downloadupstream-2fe9c95f5bea76b5e716cf28d1daefc9adf2ecb0.tar.gz
upstream-2fe9c95f5bea76b5e716cf28d1daefc9adf2ecb0.tar.bz2
upstream-2fe9c95f5bea76b5e716cf28d1daefc9adf2ecb0.zip
automatically configure switches when swconfig is installed
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15328 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/swconfig/Makefile')
-rw-r--r--package/swconfig/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/swconfig/Makefile b/package/swconfig/Makefile
index e18f556505..5959ef4c8c 100644
--- a/package/swconfig/Makefile
+++ b/package/swconfig/Makefile
@@ -38,8 +38,9 @@ define Build/Compile
endef
define Package/swconfig/install
- $(INSTALL_DIR) $(1)/bin
+ $(INSTALL_DIR) $(1)/bin $(1)/lib/network
$(INSTALL_BIN) $(PKG_BUILD_DIR)/swconfig $(1)/bin/swconfig
+ $(INSTALL_DATA) ./files/switch.sh $(1)/lib/network/
endef
$(eval $(call BuildPackage,swconfig))