aboutsummaryrefslogtreecommitdiffstats
path: root/package/spidev_test
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-03-06 01:11:44 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-03-06 01:11:44 +0000
commitcfadb8fc40656c8b62533ed9c4bcc01ca2a66763 (patch)
tree441cedd9e5ab4d10e2e77c7a93bcca94f55fc404 /package/spidev_test
parent07926f29f62e997204fddd8c1cc5ab0dc7cedf7d (diff)
downloadupstream-cfadb8fc40656c8b62533ed9c4bcc01ca2a66763.tar.gz
upstream-cfadb8fc40656c8b62533ed9c4bcc01ca2a66763.tar.bz2
upstream-cfadb8fc40656c8b62533ed9c4bcc01ca2a66763.zip
add spidev_test utility from the kernel documentation
SVN-Revision: 14753
Diffstat (limited to 'package/spidev_test')
-rw-r--r--package/spidev_test/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/package/spidev_test/Makefile b/package/spidev_test/Makefile
new file mode 100644
index 0000000000..9663b61920
--- /dev/null
+++ b/package/spidev_test/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=spidev-test
+PKG_RELEASE:=$(LINUX_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/spidev-test
+ SECTION:=utils
+ CATEGORY:=Utilites
+ DEPENDS:=@LINUX_2_6
+ TITLE:=SPI testing utility
+ VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
+ URL:=http://www.kernel.org
+endef
+
+define Package/spidev-test/description
+ SPI testing utility.
+endef
+
+define Build/Prepare
+endef
+
+define Build/Compile
+ $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/spidev_test \
+ $(LINUX_DIR)/Documentation/spi/spidev_test.c
+endef
+
+define Package/spidev-test/install
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/spidev_test $(1)/sbin/
+endef
+
+$(eval $(call BuildPackage,spidev-test))