aboutsummaryrefslogtreecommitdiffstats
path: root/package/spca5xx/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-20 02:01:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-20 02:01:53 +0000
commit4fb96c5db677ba6039ec373a1d4ed6562743bd6b (patch)
tree26c4db5d46d3e0092b66db814fde04bca3059f59 /package/spca5xx/Makefile
parent407075b86b035f91833c1fcc2aa87a3155e8c1d0 (diff)
downloadupstream-4fb96c5db677ba6039ec373a1d4ed6562743bd6b.tar.gz
upstream-4fb96c5db677ba6039ec373a1d4ed6562743bd6b.tar.bz2
upstream-4fb96c5db677ba6039ec373a1d4ed6562743bd6b.zip
cleanup, nuke obsolete 'Kernel drivers' category, convert remaining kmod packages to KernelPackage interface
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6136 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/spca5xx/Makefile')
-rw-r--r--package/spca5xx/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/package/spca5xx/Makefile b/package/spca5xx/Makefile
index e2aebfda2e..33f4ef0c47 100644
--- a/package/spca5xx/Makefile
+++ b/package/spca5xx/Makefile
@@ -22,14 +22,14 @@ PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
-#FIXME: add proper dependency handling on kmod-usb-core & kmod-videodev packages
-define Package/kmod-spca5xx
- SECTION:=kernel
- CATEGORY:=Kernel drivers
- DEPENDS:=@PACKAGE_KMOD_USB&&PACKAGE_KMOD_VIDEODEV
+define KernelPackage/spca5xx
+ SUBMENU:=Other modules
+ DEPENDS:=kmod-usb-core kmod-videodev
TITLE:=Driver for SPCA5xx based USB cameras
URL:=http://mxhaard.free.fr/
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+ FILES:=$(PKG_BUILD_DIR)/spca5xx.$(LINUX_KMOD_SUFFIX)
+ AUTLOAD:=$(call AutoLoad,90,spca5xx)
endef
define Build/Compile
@@ -43,10 +43,4 @@ define Build/Compile
modules
endef
-define Package/kmod-spca5xx/install
- $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
- $(CP) $(PKG_BUILD_DIR)/spca5xx.$(LINUX_KMOD_SUFFIX) \
- $(1)/lib/modules/$(LINUX_VERSION)/
-endef
-
-$(eval $(call BuildPackage,kmod-spca5xx))
+$(eval $(call KernelPackage,spca5xx))